AnyDesk, KDE Plasma and Wayland, AnyDesk segfault

Hi there, I have a trouble with Anydesk under KDE Plasma and Wayland compositor, always have a segmentation fault, under X11 (Xorg) works perfectly. I searched, installed all packages for Wayland related but I don’t find any solution, only seems to works on other distros like Fedora but not Manjaro.

Any help?.

When did the segmentation fault appear? → Click to open AnyDesk that crashes immediately?

I have no issue with AnyDesk when I open it.

Yes, when you launch with a launcher doesn’t run, when exec with a terminal, can see segmentation fault. With X11 (Xorg) works without problems.

It also works with KDE Wayland for me.

  1. Try to remove or move AnyDesk config:
$ mv ~/.anydesk ~/Desktop/anydesk_config_backup
  1. Then rebuild AnyDesk if it works

Doesn’t work, with a fresh config, the same error with Wayland, with X11 no problem:

$ anydesk

(anydesk:13611): Gtk-CRITICAL **: 14:49:45.044: IA__gtk_signal_connect_full: assertion 'GTK_IS_OBJECT (object)' failed

(anydesk:13611): Gtk-CRITICAL **: 14:49:45.044: IA__gtk_signal_connect_full: assertion 'GTK_IS_OBJECT (object)' failed
[1]    13611 segmentation fault (core dumped)  anydesk

The issue is with some GTK theme and config on Wayland.

Try to change bad GTK theme to other theme.

What is the version of pango and lib32-pango

Theses GTK errors also appears in X11 session but anydesk works ok, only under Wayland has a segfault. The GTK theme I using is Arc (Arc Dark) and is updated.

community/arc-gtk-theme 20221218-1 [instalado]
extra/pango 1:1.50.12-1 [instalado]

I don’t use 32 bit subsystem or repo.

AnyDesk uses the legacy GTK2 and does not support Wayland yet when using record screen on Wayland, it does not matter if you tried to fix this issue “segmentation fault”.

If you need to use it, just switch to Xorg, nothing more.

However other user under Fedora, Anydesk works under Wayland, ¿bad implementation or bug on Manjaro?. I test this into a VM or using liveCD to see is truth or not with another distros.

But Anydesk has no issue and can be opened on KDE Wayland in Manjaro testing branch for me.

AnyDesk error message is general but unclear in the terminal.
Check journalctl -b -p err --no-pager

I tested it in native Manjaro KDE Wayland in VM that has no issue.

Somewhere bad configuration or some conflict with other packages on your system.

I removed appmenu-gtk-module package for the global app menu and now runs, but can’t close from the icon system tray, not responding, do anything and I need to kill with ksysguard but now runs and works into Wayland session using as client side.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.