Any device using Intel Optane or "Intel Volume Management Device NVMe RAID Controller" doesn't boot with "mount: /new_root: can't find UUID=xxxx" error

I have a laptop with an Intel Optane H10 drive which is just a combination of two nvme drives, one of which is much faster than the other and is used for accelerating the other which doesn’t work in Linux as Intel did not make a driver for it.

So I have optane acceleration and secure boot disabled and I tried to install Manjaro many times but it did not work so I tried other distributions. List of which worked and which did not:

Ubuntu: Boots
Linux Mint: Boots
Fedora: Boots
Arch: Does not boot
Garuda Linux: Does not boot
Manjaro (Gnome, KDE, Architect): Does not boot
Debian: Does not detect the nvme disks at all

So basically the Arch distros don’t boot
All of the Arch distros had the same error that they could not find the root partition to mount it during boot and then tell the UUID of the root partition.
As I can understand all of the distros I tested use UUID for fstab. I have been trying to troubleshoot this for a very long time.
Any help is much appreciated as Manjaro is my distro of choice and I don’t want to use any of the others.

inxi -Fxxxza

I know that this is from Ubuntu. Read the whole post to understand.

  Kernel: 5.11.0-16-generic x86_64 bits: 64 compiler: gcc v: 10.3.0 
  parameters: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed 
  maybe-ubiquity quiet splash --- 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.25 wm: gnome-shell dm: GDM3 
  Distro: Ubuntu 21.04 (Hirsute Hippo) 
  Type: Convertible System: HP 
  product: HP Pavilion x360 Convertible 14m-dw1xxx v: N/A serial: <filter> 
  Chassis: type: 31 serial: <filter> 
  Mobo: HP model: 87F4 v: 39.25 serial: <filter> UEFI: AMI v: F.11 
  date: 02/18/2021 
  ID-1: BAT0 charge: 41.9 Wh (100.0%) condition: 41.9/41.9 Wh (100.0%) 
  volts: 13.0 min: 11.6 model: Hewlett-Packard Primary type: Li-ion 
  serial: <filter> status: Unknown cycles: 193 
  Device-1: hid-0018:04F3:2B55.0001-battery model: ELAN2513:00 04F3:2B55 
  serial: N/A charge: N/A status: N/A 
  Info: Quad Core model: 11th Gen Intel Core i5-1135G7 socket: U3E1 bits: 64 
  type: MT MCP arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 
  microcode: 6E cache: L1: 320 KiB L2: 8 MiB L3: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 38707 
  Speed: 1101 MHz min/max: 400/4200 MHz base/boost: 2400/4200 volts: 0.7 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 1101 2: 1165 3: 1160 4: 1101 
  5: 1100 6: 1100 7: 1107 8: 1100 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel TigerLake GT2 [Iris Xe Graphics] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 0000:00:02.0 chip-ID: 8086:9a49 
  class-ID: 0300 
  Device-2: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo 
  bus-ID: 3-6:4 chip-ID: 04f2:b6bb class-ID: 0e02 serial: <filter> 
  Display: server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting unloaded: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 158 
  size: 309x174mm (12.2x6.9") diag: 355mm (14") 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Hewlett-Packard 
  driver: sof-audio-pci alternate: snd_hda_intel,snd_sof_pci 
  bus-ID: 0000:00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.11.0-16-generic running: yes 
  Sound Server-2: PulseAudio v: 14.2 running: yes 
  Sound Server-3: PipeWire v: 0.3.24 running: yes 
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000 
  bus-ID: 0000:00:14.3 chip-ID: 8086:a0f0 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:6 
  chip-ID: 8087:0026 class-ID: e001 
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 3.0 
  lmp-v: 5.2 sub-v: 2279 hci-v: 5.2 rev: 2279 
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff 
  link-mode: slave accept service-classes: rendering, capturing, audio 
  Hardware-1: Intel Volume Management Device NVMe RAID Controller 
  driver: vmd v: 0.6 port: 3000 bus-ID: 0000:00:0e.0 chip-ID: 8086.9a0b rev: 
  class-ID: 0104 
  Local Storage: total: 519.13 GiB used: 0 KiB (0.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202AH 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B 
  speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: HPS2 
  temp: 38.9 C scheme: GPT 
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Intel model: HBRPEKNX0202AHO 
  size: 27.25 GiB block-size: physical: 512 B logical: 512 B 
  speed: 15.8 Gb/s lanes: 2 type: SSD serial: <filter> rev: HPS3 
  temp: 53.9 C scheme: GPT 
  ID-3: /dev/sda maj-min: 8:0 type: USB vendor: HP model: v236w 
  size: 14.94 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw-size: N/A size: 3.71 GiB used: 314.2 MiB (8.3%) fs: overlay 
  source: ERR-102 
  Alert: No swap data was found. 
  Missing: Required tool sensors not installed. Check --recommends 
  Processes: 282 Uptime: 7m wakeups: 822 Memory: 7.42 GiB 
  used: 2.44 GiB (32.9%) Init: systemd v: 247 runlevel: 5 tool: systemctl 
  Compilers: gcc: N/A Packages: 1853 apt: 1847 lib: 847 snap: 6 
  Shell: Bash (sudo) v: 5.1.4 running-in: gnome-terminal inxi: 3.3.06 

As always, system details are the basis for any substantial help, you could start with

inxi -Fxxxza

Added it now!

Thanks, clearly no issue in doing this from Ubuntu.

I could imagine that your RAID setup makes issues for the installer as this is rarely used, not sure if you find someone here who has the expertise to assist.

Second point: For some HP laptops issues in installation have been reported, just use the forum search engine, one example:

It could be worth to analyze your firmware settings.

The actual Intel RAID is turned off
Just the controller is called that

And the second point talks about secure boot which is also turned off

I am fairly sure it is because for some reason the root partition can’t be found during boot

@Wollie Do you need any more info from Linux or can I boot back to my system?

Thanks, you have shared most important data.

If I am not mistaken - Intel Optane is only supported using Windows OS.

1.2 Minimum Requirements

Below are the system requirements to support system acceleration with the Intel® Optane™ memory H Series.

  • Operating System: Microsoft Windows 10 x64 bit (Version 1703/Build 15063) or greater required
  • Note: The Intel® Optane™ Memory and Storage Management application (see Section 5.1) requires Microsoft Windows 10 x64 bit (Version 1803/Build 17134) or greater.

As for your boot issue - secure boot is not default supported - but it is possible to setup if you are up for the challenge.

Thanks for the reply but you did not understand my issue correctly

Nevertheless, I solved it!!!

Apparently Intel NVMe drives need the “vmd” kernel module which both Arch and Manjaro don’t include by default but Ubuntu and its derivatives do.
This is the post that helped me: [SOLVED]Grub cannot find UUID when booting / new_root: DUALBOOT, UEFI / Installation / Arch Linux Forums

I request you to send this issue to the Manajaro devs as this is a big issue with a simple fix and will increase overall compatibility.

This has also been reported as a bug in Arch: FS#68704 : [mkinitcpio] unable to boot intel nvme after install due to missing vmd module

This is a major problem, I don’t know how this has not been solved yet

More reports:


From you topic - you explicity mentioned H10 series - I am confused.

Interesting … So not officially supported by Intel - yet users expect Linux support.

What happened to the habit of verifying intented hardware compatibility if you intend to run Linux?

You did a great job of idenfying a solution :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.