Any advice on getting a current (or at least not embarrassingly old) version winetricks installed?

Hi, fairly new to Manjaro and Desktop Linux in general.

Lutris is failing to invoke winetricks complaining it’s too old. Protontricks complains too with:

warning: You are running winetricks-20210206-next, latest upstream is winetricks-20220411!

Which means the version languishing in the Manjaro repositories is now over a year old, a really long time in gaming and WINE terms.

The AUR winetricks-git package is almost as old, so no help there.

But the arch version of winetricks in multilib is 20220328-1, much more recent, according to:

Why is the Manjaro version of winetricks, a critical tool for getting WINE applications to run, so out of date? According to winetricks I should be getting is 20210825-1, which is old but not as old as what I have.

OK, after further digging… pamac claims it is installing 20210825-1, however if I run winetricks --version I get:

20210206-next - sha256sum: 0769bbcdbd92c407f4eacaa85acc1339f607dbeafe2febd1be0912034c7af3a1

So, how do I as a lowly end user sort this out? Is the repo wrong, and installing 20210206-next while claiming to install 20210825-1? And does it really matter when even 20210825-1 is pretty old anyway? The version of winetricks Manjaro currently includes very incomplete WINE 7.0 support.



That version is available on testing and unstable branches. When in doubt, use Manjaro - Branch Compare


This is how the branches work

Wine is not a critical linux application tho … hence nor is winetricks

You have two alternatives:

  1. switch branches
  2. install winetricks from an unstable mirror (for example) with this command:
sudo pacman -U

Arch repository package was flagged out of date yesterday
Arch Linux - winetricks 20220328-1 (x86_64)

1 Like

Thanks for the response,

But what about the fact that 20220328-1 is not installing 20220328-1, but is installing 20210206-next?

I installed the winetricks-20220328-1 package as suggested and it still reports its version as 20210206-next when I run winetricks --version. Is it possible the package maintainer is releasing the same package over and over again but with a different label? This builds directly from git, doesn’t it? How much room is there for human error?

It is possible winetricks is misreporting its version?

I have reported the issue here:

But it seems really unlikely that winetricks has been misreporting its version for over a year, isn’t it? Protontricks and Lutris kick up a stink about the old version. Starting winetricks --gui complains about the ancient version.

Is anyone able to confirm/deny that winetricks --version doesn’t match the version reported by pamac? It would be helpful if I wasn’t the only person claiming there’s an issue.


If you can’t wait for the latest version you could run a self-update independent of package managers

sudo winetricks --self-update

pamac would still report the older version (20220328-1) installed
but winetricks --version should report the latest version (20220411-next)

You might need to rollback to earlier version when it is available in Manjaro repository

sudo winetricks --update-rollback