Antivirus blocks update for Manjaro on virtualbox

I just installed latest Manjaro as Virtualbox Guest on my Windows 10 PC on which Quickheal Antivirus is installed. When I tried to update Manjaro in Virtualbox, my Antivirus blocked the access to the Update mirror saying that visiting this site could be dangerous.
I thought that the mirror could be infected so decided to change the mirror. But to my surprise, the update is not accepting my administrator password. I know I am inputting correct password. I even tried to reinstall the whole OS but the result is same. Prese guide because without update the OS is useless and I don’t want to disable my antivirus and allow the access to that mirror.
Thanks

What i just read reminds me of:
I want to make an omelette without breaking any eggs, and i don’t want to use fire or any heat source either!

There are no mirrors infected with any malware.

From within Manjaro host install, you mean the Pamac UI is not accepting your password when making changes? How about from terminal?
sudo pamcan-mirrors -f && sudo pamcan -Syyu

To whatever mirror you want to use, you will have to make a rule in your antivirus software to allow access to it.
Welcome!

Very cautious of you. However, if you think you know better than your antivirus then you should tell it so - and if you can’t, then you should just turn it off so you can do what you want to do.

I’ve updated from various repositories since 2007 and I haven’t used anti-malware software since then - I can assure you that there isn’t any risk.

With Linux, we use ‘Timeshift’ so that IF anything did go wrong, everything can be restored in about 15 minutes - so my advice is just to do a backup and get the job done.

Why do you install a discount exotic software to replace Windows Defender.
On W 10, you don’t need to install any third party anti-virus as long as your Windows Defender is active and Virus and spyware definitions are up-to-date.

In addition, any Windows anti-anything is totally useless for a Linux install

If you really keep having problems with this bloatware, try a dual boot, at least it won’t interfere.

1 Like

Thanks for the reply. Regarding the password, yes the pamac (policy kit KDE) is not accepting my password. Surprisingly, even when I installed the OS with my defined User account, it is not showing my username selected at the time of installation but instead showing Manjaro as username. Also, it is still showing Install Manjaro shortcut on the Desktop, so I suspect that it is still running the bootable OS rather than full OS. This is the reason why it is not accepting my password chosen at the time of installation. I tried to install twice with the same results. Not sure why it is not installing full OS on the virtual drive. Here I will mention that I am not a novice to Virtualbox installation with Mint cinnamon and Kubuntu already installed as other Virtual Guests on my PC. Just not getting this one.

That means you still have the ISO attached to the Virtual CD/DVD and you are booting from it. Remove it and try again.

Thanks for the immediate reply. I am afraid I don’t know how to do that. When I installed Linux Mint and Kubuntu as Guests, I did not have to do that. These Virtual Machines boot straight into main OS and not from the ISO. Please advise how to do this. Of course, needless to say that the ISO is downloaded on the host machine hard drive and mapped on the Virtual machine. There is no USB drive that I can remove from the PC.

To do what “that” are you referring exactly?

So you used Virtual Box appliances aka Virtual Box images from here?

And as i said:

image

That needs to be empty, aka unmounted in order to not boot from it.
But none of this are related to your initial OP issue

Please deal with that first.

1 Like

Thanks for the reply. With the reply posted I could figure out and remove the ISO from being loaded. This allowed the main OS to load, accepted my login name and password and installed the updates. Thank you all for the support provided. We can close this thread now.

Just a tip, there is no need to install a 3rd party firewall or antivirus on Windows 10. The built in one is fine, and a lot less false issues.

3 Likes

to OP: so i just had a similar incident where Malwarebytes was blocking truenetwork(dot)ru. I’m running manjaro in a VM on a Win10 machine, but i was just running it and not attempting an update or anything. this actually happened with an install of vanilla Arch that i did on the same machine using the same hypervisor, but not with the same mirror. That alert came after the Arch install was trying to access archlinux(dot)thaller(dot)ws and mirror(dot)cyberbits(dot)eu.

I’m not sure, but it looks to me that these sites are just suspect for malwarebytes and they set off alarms but aren’t actually doing anything.

It’s weird though… i have used manjaro on a VM before and never set off any alarms like this. must be a new thing. :man_shrugging:

In my case, I informed my antivirus support of the blocking of this supposedly suspicious site, ever since I informed them, now there is no blocking. I am using the same mirror to update now. It seems they are doing it erroneous.