Ansible broken since last update


Since an update of my system, Ansible is not working.
The ansible answers :

ERROR! Unexpected Exception, this is probably a bug: module ‘ansible.constants’ has no attribute ‘CONTROLLER_PYTHON_WARNING’
the full traceback was:

Traceback (most recent call last):
File “/home/user/.local/bin/ansible”, line 76, in
AttributeError: module ‘ansible.constants’ has no attribute ‘CONTROLLER_PYTHON_WARNING’

I don’t know exactly which update it is because I didn’t notice this issue immediatly and what package is responsible.

I tried to reinstall and downgrade Ansible.
I tried to downgrade Python.
I tried to force use Python3 or Python2 but nothing changes.

I don’t understand this error.

I used a lot ansible and ansible-playbook and overnight I get this error.

What can I do ?


Use the system ansible and not your own home made version. Or rebuild your Home made version against the current system libraries.

This isn’t a good approach make sure you go back to the current python version.

1 Like

I always used my ansible in this configuration because it was installed like that with pacman. And it worked well.

How can I rebuild my ansible ?

For Python downgrade, that was just a test and I went back to the latest version.

It is not about your configuration. You have a binary in your home folder. Pacman does not install files to your home folder!
You musst at least changed your PATH variable and added a file called ansible to this folder.

The ansible from the pacman package is located in /usr/bin and not in your home.

If you don’t know how you build and installed this third-party binary in your home folder, nobody knows. You should know what you did to your system.

1 Like

Thank you I found the problem.
I never changed this configuration and I don’t know my ansible is now in .local/bin…
By running “ansible”, I have the problem but “/usr/bin/ansible”, it works.
I deleted all files ansible* in my .local/bin and now it works.

I don’t know what happened.

Thanks for your help

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.