Annoyance with diacritics and marks using Gnome and pt_BR keyboard

I very recently installed Manjaro (GNOME) and even though I could easily customize many things, there is one little thing that is annoying me, although not really causing big problems.

My keyboard layout is the brazilian portuguese, and I need to write words with á, ã, õ, à etc quite often. The traditional way of doing that on keyboards for me has always been to press the “diacritic” key and then the letter. But for some reason, here when I type the letter, the mark already appearts with an underline as a visual cue telling me what key I have pressed and that it is waiting for the next letter.

Even though this sounds like a good idea, it is annoying. I have been using Ubuntu for a few years now, and there when I pressed one of these keys, nothing would happen until I pressed the second key, and that feels a lot more natural.

The real problem comes when I’m writing markdowns, as it is very common to type “backticks” `, sometimes triple backticks, and this “visual cue” has tricked me into thinking that I have already typed them, making me mistype a bunch of things.

Is there a way to make it not show the underlined character until the sequence is over? I have no idea if this is necessarily related to Manjaro, but I would absolutely love it to not be like this.

Thanks a lot (:

Some commands I ran that might help (I hope they do):

$ localectl status
   System Locale: LANG=en_GB.UTF-8
       VC Keymap: br-abnt2
      X11 Layout: br
$ cat /etc/vconsole.conf 
$ cat /etc/X11/xorg.conf.d/00-keyboard.conf
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "br"
1 Like

This is what this looks like: