"An application" disables compositor on startup after setting Force Full Composition Pipeline to true

I found out that with NVidia cards, setting Force Full Composition Pipeline to true improves the performance of KDE Plasma a lot, thank God for whoever posted it because it’s true
I’ve played around with that setting and others (aka followed advice online) until I finally found a way to make it work well in Plasma as well as not stutter and tear in games
Except I’m left with one, small but annoying problem… Every time I boot my PC, the compositor is disabled with this message:
Screenshot_20201018_160742
If I press Ctrl+Alt+F12 my entire screen goes black (I have just realised, while typing this, that it says Shift+Alt+F12, so that’s one mystery solved), but if I go into settings, switch the compositor to OpenGL 2.0 and then back to 3.1, everything works great again
I made this change in nvidia.conf:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option         "TripleBuffer"  "On"
    Option         "ConnectToAcpid"    "Off"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline = On}
EndSection

Why does it do that ? It’s annoying that I have to switch it back on every time I boot my PC, and I’m worried I’ve done something wrong

System info:

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=4ca7b8df-89fc-4e55-990d-f53f2ac04688 rw quiet 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: MSI model: X370 KRAIT GAMING (MS-7A33) v: 1.0 
  serial: <filter> UEFI: American Megatrends v: 1.J1 date: 05/13/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001138 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 76833 
  Speed: 3094 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 3094 2: 1279 3: 1360 4: 3397 5: 1378 6: 1360 7: 1359 8: 3399 9: 2704 
  10: 1355 11: 1376 12: 1360 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660] vendor: ASUSTeK driver: nvidia 
  v: 450.66 alternate: nouveau,nvidia_drm bus ID: 27:00.0 chip ID: 10de:2184 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 4640x1080 s-dpi: 86 s-size: 1368x318mm (53.9x12.5") 
  s-diag: 1404mm (55.3") 
  Monitor-1: DVI-D-0 res: 1280x1024 dpi: 86 size: 380x300mm (15.0x11.8") 
  diag: 484mm (19.1") 
  Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") 
  diag: 598mm (23.5") 
  Monitor-3: DP-0 res: 1440x900 dpi: 89 size: 410x260mm (16.1x10.2") 
  diag: 485mm (19.1") 
  OpenGL: renderer: GeForce GTX 1660/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
  direct render: Yes 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 27:00.1 chip ID: 10de:1aeb 
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 29:00.3 chip ID: 1022:1457 
  Device-3: Logitech G430 Surround Sound Gaming Headset type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 7-4:4 chip ID: 046d:0a4d 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: f000 bus ID: 22:00.0 chip ID: 10ec:8168 
  IF: enp34s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 2.49 TiB used: 1.84 TiB (74.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Kingston model: SV300S37A480G size: 447.13 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: BBF0 scheme: GPT 
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC26 scheme: MBR 
  ID-3: /dev/sdc vendor: Samsung model: MZNLN256HMHQ-000H1 size: 238.47 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 1H3Q scheme: GPT 
Partition:
  ID-1: / raw size: 250.54 GiB size: 245.60 GiB (98.03%) 
  used: 164.09 GiB (66.8%) fs: ext4 dev: /dev/sda5 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 19.68 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 43.2 C mobo: N/A gpu: nvidia temp: 36 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 29% 
Info:
  Processes: 354 Uptime: 16m Memory: 15.64 GiB used: 3.45 GiB (22.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1645 
  apt: 0 pacman: 1624 lib: 431 flatpak: 10 snap: 11 Shell: Bash v: 5.0.18 
  running in: konsole inxi: 3.1.05

Hi!
Go to compositor settings and you’ll find and option to allow apps to break compositor or something like that, sorry, I’m not in plasma right now. Just disable that option and check

1 Like

Oooh, this worked ! I guess I’ll have to disable the compositor myself when I play games though, but that’s not that big of a deal
Thanks !