Amdgpu-experimental on kernel 5.10


I have an unusual setup, but I’m running Manjaro on a computer with a AMD R7 350 with the intent of outputting a VGA signal to a CRT TV to run RetroArch. It took a long time to setup but it works great.

I have to use the amdgpu-experimental drivers to get Vulkan support on this video card, which is very important for performance-related reasons on my setup. This setup works both on kernel 5.4 and on kernel 5.9. I just installed the package, I’ve heard about kernel modules and blacklisting and so on but I have no idea how any of that works to be honest.

I tried switching to kernel 5.10 and what happens is that the operating system does not find the VGA output - xrandr does not even list it, it just shows the other video outputs. As soon as I revert back to 5.9 the output is there.

Now, I might be misremembering, but I think the same happened on 5.9 a while ago, so maybe something changed to make it work now - maybe amdgpu-experimental got updated to support 5.9 and I have to wait for it to be updated for 5.10?

Anyway, my question is, why does this happen? Can I fix it somehow so I can move to kernel 5.10? Do I need to worry about support for my kind of setup dropping? Do I have to always stay one or two kernel versions behind?

It it very strange that the VGA port just disappears when running kernel 5.10. I tried looking this up but I couldn’t find any information.

amdgpu-experimental package is pretty outdated compared to the amdgpu built into the kernel.

I’m replying here to note that I kept researching and I finally found relevant information. According to this and this, the 5.10 kernel has the amdgpu drivers supporting my video card - including Vulkan support - but they still do not support analog output.

Since this is a major requirement for me - it’s the main reason I built this computer, actually - then I’ll stick with the previous LTS release, 5.4, until they manage to get analog output working on the new amdgpu support. Possibly indefinitely, which wouldn’t be a problem for me anyway.

Thanks for the reply, realmain. I’ll mark this as the solution to keep this information around for future reference.

The simple tweaks it performs is still current. What it does is outlined here: AMDGPU - ArchWikiand_Sea_Islands(CIK)_support

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.