AMD vs NVIDIA // screen tearing

Hi guys,
I ran Manjaro for over a year and had screen tearing which I was not really able to get rid of. About 3 month ago I started testing out other distribution but they also had the same problem. I even installed Windows to check it there, to make sure its not my graphic card which is defective. There everything was fine.

Yesterday I came crawling back to Manajaro as I like it the most and all other distributions had the same issue. But after the installation yesterday it was gone. No tearing everything was fine. A few hours back my Desktop froze somehow and I killed it with “CTRL+ALT+Backspace” and since then the tearing is back again. I tried everything again but it did not work the tearing is back and it is here to stay.

So I was wondering if the same issues occur with AMD or if it would be worth to switch?

here is my current System:

  • Ryzen 1600X
  • 16G Ram
  • NVIDIA GTX 1070ti
  • Samsung 50" 4k TV

Thanks in advance and kind regards

After every reboot, you need to enable Force Full Composition Pipeline in Nvidia Settings panel (proprietary driver). Tearing gone immediately. Until next reboot, I wrote a script for that when I was using 1080Ti. This works on every distro. You could have enabled it months ago :slight_smile: I had same situation, I was stuck with tearing for long time, I didn’t know any better.

I sold 1080Ti two months ago. Radeon 5700XT has no tearing at all, out of the box works perfectly.

1 Like

I can only confirm that. Since I switched from a GTX 1050 ti to an RX 580, the issue has been settled for me.

Thank you very much for your answers.
I guess then I will have to buy a new card.
Thank you very much for the information.

1 Like

Hi omano,
Thanks for the link.
I never tried the compositer setting. Unfortunately it also did not do the trick for me.
I just ordered an AMD 580. I hope that will fix the issue for me.

1 Like

Great! Please report back once you have it :slight_smile:

The “fix” is not in kwin, but there are multiple steps. Click and open album and read.

Hi onano,
Thanks for the hint. unfortunately that does not work for me. In the past I went through so many sites and information. I tried everything noted in the arch NVIDIA/Troubleshooting Guide.
Why can´t I post the link to the guide?

The AMD Card should arrive today, I hope that will fix the issue once and for all.
I will report back as soon as I was able to verify it.

Hello everyone,
I installed my new AMD RX580. For some reason, I had a problem, that it did not recognize the resolution 3840x2160 60Hz. But since I created that mode with xrandr everything is running smoothly. I do not have any tearing anymore and it even feels smother.
So far I am very happy with the result.

To apply the changes permanently I just added the following script to the KDE Autostart

xrandr --newmode “3840x2160R” 533.00 3840 3888 3920 4000 2160 2163 2168 2222 +hsync -vsync
xrandr --addmode HDMI-A-0 3840x2160R
xrandr --output HDMI-A-0 --mode 3840x2160R

1 Like

Fantastic :heart_eyes: Enjoy your tear free experience, and no need to install proprietary drivers ever again. :grin:

Show us the script? (For xfce)

1 Like

I guess you can use the same script as I wrote above.
I usually only read howtos, but I will do my best to explain it.

You can create the parameters that are needed to change the refresh rate with the flowing command:

cvt --reduced x y f

(x and y are the resolution and f is the frequency)

For me it looked like that:

cvt --reduced 3840 2160 60

This was the output:

3840x2160 59.97 Hz (CVT 8.29M9-R) hsync: 133.25 kHz; pclk: 533.00 MHz
Modeline “3840x2160R” 533.00 3840 3888 3920 4000 2160 2163 2168 2222 +hsync -vsync

You can now either use the whole string (Modeline …) and update your xorg.conf or apply it with xrandr temporarily.
As I did not want to invest the time to find out, which Screen in the xorg config corresponds to which of my physical screens I just took the commands and let them apply by autostart.

You can also copy nvidia.conf from /etc/X11/mhwd.d and make a new file in /etx/X11/xorg.conf.d called 95-mhwd.conf, paste the contents of nvidia.conf into your new file (95-mhwd.conf) and add either Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }" or Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline=On }" depending on what works the best for you (You place that in Section “Device”). That should make the Force Full Composition Pipeline automatically be turned on at startup (or Force Composition Pipeline if you chose that).

No, I don’t want the script. I want to know how to configure manjaro xfce to start a certain script on bootup. (As it will automate many repeating tasks on boot increasing my productivity)

here is a forum thread for that topic:
How to run a script on system startup

1 Like

@Atlan getting this.