Amd Radeon 5700 XT low performance

Hello there!

I recently did a complete system update because my Amd Radeon 5700 XT had been crashing regularly before kernel 5.8 and its performance has been very low ever since (~130 average fps in CS:GO, ~4000-12000 glmark2 score, no smooth video streaming).

Are there common ways to start debugging issues that could be related to this?

System information

❯ inxi -Fxxx
System: Host: zill Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: Xfce 4.14.2 tk: Gtk 3.24.20
info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine: Type: Desktop Mobo: ASRock model: Z270 Pro4 serial: <superuser/root required> UEFI: American Megatrends v: P2.70
date: 03/16/2018
CPU: Topology: Quad Core model: Intel Core i7-7700K bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 8192 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 67224
Speed: 930 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 1860 2: 1947 3: 1689 4: 1988 5: 1768 6: 1972 7: 1683
8: 2046
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] vendor: ASUSTeK
driver: amdgpu v: kernel bus ID: 03:00.0 chip ID: 1002:731f
Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: vfio-pci v: 0.2 bus ID: 06:00.0
chip ID: 10de:1c03
Display: x11 server: X.Org 1.20.8 driver: amdgpu resolution: 1: 1920x1080 2: 1920x1080~60Hz s-dpi: 96
OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.38.0 5.8.6-1-MANJARO LLVM 10.0.1) v: 4.6 Mesa 20.1.7
direct render: Yes
Audio: Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a2f0
Device-2: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel v: kernel bus ID: 03:00.1
chip ID: 1002:ab38
Device-3: NVIDIA GP106 High Definition Audio vendor: ASUSTeK driver: vfio-pci v: 0.2 bus ID: 06:00.1
chip ID: 10de:10f1
Device-4: Logitech Logitech G633 Gaming Headset type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-9:4
chip ID: 046d:0a5c serial: 00000000
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network: Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6
chip ID: 8086:15b8
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:50:33:b7
IF-ID-1: virbr0 state: down mac: 52:54:00:88:12:3f
IF-ID-2: virbr0-nic state: down mac: 52:54:00:88:12:3f
Drives: Local Storage: total: 3.75 TiB used: 1.17 TiB (31.2%)
ID-1: /dev/sda vendor: Toshiba model: HDWD130 size: 2.73 TiB speed: 6.0 Gb/s rotation: 7200 rpm serial: 78BWD5TAS
rev: ACF0 scheme: GPT
ID-2: /dev/sdb vendor: SanDisk model: SDSSDP128G size: 117.38 GiB speed: 6.0 Gb/s serial: 140710405777 scheme: GPT
ID-3: /dev/sdc vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: S2RFNX0J126430R
rev: 2B6Q scheme: GPT
Partition: ID-1: / size: 80.84 GiB used: 62.58 GiB (77.4%) fs: ext4 dev: /dev/sdb2
Swap: ID-1: swap-1 type: partition size: 34.44 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3
Sensors: System Temperatures: cpu: 74.0 C mobo: 37.0 C gpu: amdgpu temp: 62 C
Fan Speeds (RPM): fan-1: 0 fan-2: 2064 fan-3: 0 fan-4: 0 fan-5: 0 gpu: amdgpu fan: 995
Voltages: 12v: N/A 5v: N/A 3.3v: 3.31 vbat: 3.18
Info: Processes: 306 Uptime: 17m Memory: 31.33 GiB used: 3.41 GiB (10.9%) Init: systemd v: 246 Compilers: gcc: 10.2.0
Packages: pacman: 1330 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.05

I have also set the grub parameters amdgpu.noretry=0 and amdgpu.gpu_recovery=1.

Any help would be greatly appreciated! :grin:

Hello,

first i would open htop and radeontop on a second screen and watch the load while playing or run the game with mangohud to detect the bottleneck.

Greetz

1 Like

Hi, thanks for the suggestions.

I couldn’t see much from htop or mangohud regarding extreme CPU usage (~40 % in CS) but both radeontop and mangohud periodically showed GPU usage spikes to over 90%.

1 Like

Do you use the gamemode?

pamac install gamemode

Don’t forget to activate it:

systemctl --user enable gamemoded && \
systemctl --user start gamemoded

and start the game with

gamemoderun %command%

yepp seems your GPU can’t do more.

1 Like

No i don’t currently. I’ll take a look at that.

The problem is that I had 300+ average fps at least in not so demanding games like CS:GO before updating to the latest drivers. Is there a way to roll back those graphics drivers?

Also when auto installing the open-source-driver via mhwd it also downloads drivers for the Nvidia GPU which is only used for VM passthrough. Could that have an impact?

1 Like

You try to use downgrade (you have to install that)

The run:

downgrade xf86-video-amdgpu

Do it on your own risk.

Possible, but only if both GPUs are running and game. But i am not 100% sure.

1 Like

Thanks for the suggestion again :smiley:.
I also just found this arch wiki thread about downgrading packages and might try reverting the changes via the package manager first after reading about the potential dangers from reverting the packages.

But I think I’ll wait for other suggestions as well before attempting the downgrade.

1 Like

So …
I see you have a dual-gpu set up …
are you sure you were using the amd card in the past?
Is there a reason you arent using the nvidia (for things like games … )?

Meh … looks like the nvidia is considered weaker. hm.

1 Like

I got the amd card as an upgrade to the nvidia one and was using it before. Up until kernel 5.8 it often caused Xorg to crash. At least that is fixed now.

The nvidia card I use in a virtual machine running windows 10 for playing windows only games. I accomplished that via this arch wiki thread.

Yeah fair enough.
I saw ‘nvidia 10…’ and assumed it was the more powerful card :wink:

1 Like