AMD discrete GPU cannot be initialised

I built a full-AMD desktop today. The CPU is actually an APU with integrated graphics and the discrete GPU is a RX6950XT. Manjaro boots fine with Linux 6.5 and 6.1, but freezes with 5.15. My issue is that the discrete graphics card is not initialised and if I plug in my monitor in that (HDMI, have not tried with DP) I don’t get any signal (and I cannot see GRUB either if it matters). However, the GPU is recognised, but the driver not loaded:

lspci -k | grep -A 3 -E "(VGA|3D)"                             
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21 [Radeon RX 6950 XT] (rev c0)
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21 [Radeon RX 6950 XT]
	Kernel modules: amdgpu
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Navi 21/23 HDMI/DP Audio Controller
12:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Raphael (rev c6)
	Subsystem: Gigabyte Technology Co., Ltd Raphael
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

This is the output of dmesg | grep amdgpu:

[    7.566584] [drm] amdgpu kernel modesetting enabled.
[    7.566602] amdgpu: vga_switcheroo: detected switching method \_SB_.PCI0.GP17.VGA_.ATPX handle
[    7.575910] amdgpu: CRAT table disabled by module option
[    7.575913] amdgpu: Virtual CRAT table created for CPU
[    7.575924] amdgpu: Topology: Add CPU node
[    7.576008] amdgpu 0000:03:00.0: enabling device (0000 -> 0003)
[    7.576090] [drm:amdgpu_discovery_set_ip_blocks [amdgpu]] *ERROR* amdgpu_discovery_init failed
[    7.576227] amdgpu 0000:03:00.0: amdgpu: Fatal error during GPU init
[    7.576229] amdgpu 0000:03:00.0: amdgpu: amdgpu: finishing device.
[    7.576255] amdgpu: probe of 0000:03:00.0 failed with error -22

Any clues?

Check this post; same error and solved by

setting amdgpu.dpm=0

Does not solve. Actually, does not boot at all. And it is not the same error as the post you linked. I also tried amdgpu.aspm=0, boots but still not response from the discrete card.

I ended up solving by disabling the iGPU at a BIOS level. Now it seems to be working.