Amazon prime video not working

On Firefox the WidevineCdm plugin crashes, but this might be also because I use some security and privacy oriented components.

So I tried with Chromium, but Amazon reports error 7235 and says to check it says that Widevine Content Decryption Module (Versione: 4.10.1610.0) and infact it says is not updated. I run all the updates but is the same. Chromium is version 87.0.4280.66 Arch Linux 64 bit.

I tried also the procedure at (cannot link post) /2019/09/24/how-to-install-latest-widevine-plugin-on-chromium/ but didn’t help. Here the script:

unzip $
sudo mkdir /usr/lib/chromium
sudo mv /usr/lib/chromium
sudo chmod 644 /usr/lib/chromium/

What I can do?

Hello @stevexyz :wink:

Firefox 84.0.1 has Widevine with version 4.10.1582.2 on the testing branch.

For chromium you will need to install chromium-widevine (version 4.10.1679.0 atm):

pamac build chromium-widevine

I’m watching Amazon Prime without chromium-widevine:

FYI, Firefox 84.0.1 is on all branches at the moment. @nightmare-2021 and I are working on pushing Firefox and Chromium updates to all branches when there’s a new release.


I’ve tried the pamac build chromium-wide and it’s working!
Thank you!!

Can someone explain me why I am able to watch these videos without chromium-widevine installed? Really: I know that is needed for DRM contents, so I am surprised that I am able without chromium-widevine :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.