Always new network connection on every reboot

Hey there,

I’m using Manjaro with KDE Plasma 5.23.4.
I’m having an interesting issue I don’t know how to fix: Every time I reboot, my PC connects to the network, but always shows it as new network, which also means that any configuration for the network isn’t saved.

I think that wasn’t that great of an explanation, but I don’t really know how to phrase it better, however, screenshots might help deliver my point:

So, here it can be seen that I’m connected to a network named “enp0s31f6” (probably my network card) and below is another network, with exact the same name and properties, but it’s not connected. The unconnected one is the one I used before the reboot, the one I’m connected to is the new one.

I need to access my PC from time to time by IP-Adress, so I need to manually configure it; but I don’t want to have to do this on every reboot and I also didn’t have this issue on Kubuntu 21.10 with KDE Plasma 5.23.2.

Has someone an idea how to fix this?
Might some service be configured in a wrong way?

Thanks in advance!

Do you use DHCP ?
Do you get the same IP every time you connect ?
Do you change the MAC ?

I would suggest to look into the config of your router. There you often have an option:
Every time when this device (recognized by this MAC) connects, give it the same IP.

Hi, thank you for your reply! :slight_smile:

I think I was not using DHCP; I hope I activated it now, I’ll test in a few moments.
I don’t get the same IP adress and don’t change the MAC.

It’s also not an issue of the router, as on other distros I don’t have this issue and other PCs running Manjaro don’t have it either.

Okay, I tested it with DHCP, I still get a new connection at every reboot :frowning:

I made an interesing finding: when activating one of the old connections, the new one disappears and I can use the “old” one.
Don’t know if that helps

EDIT: Another interesing finding: my dmesg gets spammed when changing the network.

Could this also help?

There are a few times when the interface drops and gets up gain, not sure from the log why.
This is probably your Ethernet card: e1000e that the log refers to as going down and up.
This might be a interesting thread. I’m not certain it applies to this situation but the op in the thread has similar symptoms and from the log the same network card.

Could you posts some more info about your system and maybe the error log from the journal?

$ inxi --admin --verbosity=7 --filter --width
$ journalctl --boot  --priority=err 

Off course, the inxi log can be found here:

The journalctl log here:
The journalctl was quite big, so I had to upload it to GDrive, I hope that’s okay. :sweat_smile:

EDIT: A driver I use spammed the log, I tried to filter it, here is the “cleaned” version:

OK, I managed to solve it:
The issue was that systemd-networkd.service and systemd-networkd.socket were enabled and running.
Disabling them and restarting the system solved the issue, now everything is working as expected. :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.