AltGr key not working in non-KDE applications since recent update

For about 2 years I am running the latest Manjaro KDE Plasma with language set to US English and a keyboard with German/DE layout. Since one of the recent updates my keyboard is behaving funnily:
My AltGr key (right Alt) is not working in non-KDE applications and Konsole.
I have selected the “Generic 104-key PC” keyboard with DE layout. In the Layouts tab I have set the “3rd level shortcuts” to “Right Alt”. In the test area in the Keyboard → Hardware tab the AltGr key works as expected. I can type |, @, €, {, [, ], ~ etc. just fine. It is also working fine in the Kate text editor, QtCreator and Dolphin.
However it is not working in Konsole (bash), Firefox, Thunderbird, LibreOffice and all other non-native KDE apps.
I am running out of ideas what else to try. Do you have any ideas?

DE Plasma Version: 5.27.6
KDE Frameworks Version: 5.107.0
Qt Version: 5.15.10
Kernel Version: 6.1.38-1-MANJARO (64-bit)

You should probably set this to a 105-key keyboard.

You should not do this either, because this will override the normal mapping of the AltGr key.

Thanks for the reply. Switching to the Generic 105-key keyboard didn’t change anything. I have tried the “Defaults” button to reset everything. Funnily this resets the keyboard to 104 keys. At least it unbinds the 3rd level shortcuts. I remember having to set this because I ran into the AltGr key not working before. Back then this restored the AltGr functionality.

However the problem persists. AltGr only works in “native” KDE applications.
Trying to type “~” (“AltGr +” on a DE Layout) in Konsole only lists all users.
Typing “@” (“AltGr q”) shows this:

::1 ff02::2 ip6-allrouters ip6-loopback my_pc_name
ff02::1 ip6-allnodes ip6-localhost localhost

All other key combinations using AltGr remain unusable.

I am using Plasma and a dk layout with the Generic 104-key PC.

I am using that key for a lot of typing - so I would have gone bonkers if it stopped working.

The claim that AltGr only works with native KDE cannot be replicated on my system.

I am using that key for a lot of typing - so I would have gone bonkers if it stopped working.

Same for me. Also not being able to pipe something in the terminal was really annoying (typing “|” on a DE layout also requires the AltGr key).
Apparently the changes above required a reboot/logout to become effective. Looks like it is working again. (I had rebooted into the “backup” 5.15 kernel where it worked as expected and then back into the 6.1 kernel). Regardless of 104/105 keys keyboard and even without the additional assignment of 3rd level right alt everything appears to be back to normal.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.