Alternative Ways to Script a Forward Slash?

I have a peculiar problem with a PinePhone/Phosh framework/xfce desktop: the following commands do not produce a forward slash. The commands work in my other Manjaro/xfce setups, so this is a bug in Phosh/xfce, and I’m wondering if a veteran here can offer an alternative to these failed commands:

xdotool type /
printf '\x2f'
echo '/'

Thanks for any suggestion.

Your statement Phosh/xfce how it that to be understood?

You are connecting to the the phone using ssh from a xfce desktop?

Under what conditions do you miss / ?

I have checked my pinephone with Phosh - no issues.

printf '\x2f' and echo '/' works for me in xfce4-terminal with BASH shell, so alternatives may or may not work in phosh:

printf %s \/
printf %s "/"
echo \/
echo -e "\x2F"
echo "2f" | xxd -p -r
echo "16i 2F P" | dc
echo "10i 47 P" | dc
echo "47" | awk '{ printf("%c", $0); }'

Thank you for weighing in.

@ nikgnomic – what an array of alternatives! I tried them all but when calling the script in terminal, the cursor blinks once, as if processing, but produces no forward slash.

@ linux-aarhus – I’ve installed the xfce desktop on top of Manjaro Phosh Beta ver 33. That blew out the top row of special characters (which worked in Phosh), hence my scripting to call them. As for the need for a modifier to produce a forward slash, my us keymap has been edited to make the ? key a Right_Shift, Left_Shift + ? = ?, and AltG + ? = forward slash

For some reason, xfce is willing to let my us keymap generate a Right_Shift, just not a third-layer modifier to produce a forward slash.