All key function in lenovo ideapad slim 3 is not working for manjaro kde

Hello i bought a lenovo ideapad slim 3 laptop and installed manjaro kde on it. But my question is that most of the keyboard key is not working as expected. What should i do ?
my system info

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.10.60-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Pentium® CPU G4400 @ 3.30GHz
Memory: ১৫.৬ GiB of RAM
Graphics Processor: GeForce GT 1030/PCIe/SSE2


  • Laptop devices are built so the function keys will have extra functionality which is activated using the Fn associated with the extra function.
  • Further some devices invert this so you need to use the Fn key to get the Fxx functionality!

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.