All home folders show on desktop

All folders in my /home directory show on my desktop.
When I create a new /home folder, it also shows on my desktop.
Any idea how to fix this? Extremely frustrating.


A user’s home directory is /home/$USER, where $USER is your logon userid. On the command line type, echo $HOME $USER

If you right click the XFCE desktop, select “Desktop Settings”, and then click the “Icons” tab, at the bottom there is a section, “Default Icons”. You can unselect “Home”, but again that is /home/$USER.

With “Home” selected (and Icon type = File/launcher icons), anything you put into /home/$USER/Desktop will appear on your XFCE desktop.

Also expand “Removable Devices” and check there.

You can also get to the desktop settings from XFCE’s Settings Manager > Desktop > Icons.

Some doc at

The doc mentions the environmental variable $XDG_DESKTOP_DIR. On my system that variable is not set.

Stargazer, thanks, but not quite what I’m having trouble with.
I have a number of distros, *bsd systems all with xfce4.
Perhaps I should rephrase what is happening. I know the home folder normally appears on Desktop, but why does my Music, Documents, Downloads, irclogs, Mail, etc folders appear on my Desktop even though they are in my /home/$USER directory?
Even when I create a new /home/$USER folder, it suddenly shows up on Desktop, even though when listing the Desktop directory via cli, the new folder, along with other folders I just mentioned, aren’t listed?
Does that make sense?
To help, I do not put anything under /home/$USER/Desktop :slight_smile: They just show up there even though the files/folders are only in /home/$USER.

You can choose any folder for your desktop, it looks like your desktop is not the Desktop, but rather the User folder containing all your Home directories.

Deleted .config/xfce4 and that didn’t help. ls -alF under ~/ didn’t show anything amiss.
Under ~/Desktop, ls -alF shows everything correctly.

Created a new user and moved needed files/folders from old user to new user.
Yes, did change owner:group settings for everything.

Will continue to play with old user to try determine what happened.

Seems like a misconfiguration in your user directories. Open the file ~/.config/user-dirs.dirs with a text editor and make sure that its contents are like the ones mentioned in the Arch Wiki:

Pay attention to the entry XDG_DESKTOP_DIR="$HOME/Desktop".

1 Like

Yes, I checked that before and it was correct :slightly_smiling_face:

Thank you!

If it works, mark that comment as solution

Just an interesting note, KDE exposes the ~/.config/user-dirs.dirs variables in the System Settings GUI (System Settings > Personalization > Applications > Locations). I just assumed the default values were the same in XFCE. Now looking at this file, I see they are not.