All audio is now 32 bit?

My 16 bit and 24 bit files are now playing back as s32le when checking in pacmd list-sink-inputs.

I have /etc/pulse/daemon.conf configured as s24le as the default bit depth.

Sample Rate is correct and is not being resampled, as I have defined in the pulse daemon.conf.

This is happening on both of my manjaro machines running XFCE. One machine outputs via USB, the other via SPDIF to my Grace Design SDAC .

Previously 16 bit files played at 16 bits, 24 at 24 bit.

Did something change?

If you check in pactl list sinks it will probably show PulseAudio is processing audio with sample-format of 32bits. But response will probably also report that audio device in ALSA only supports bit depth up to 24 bits
alsa.resolution_bits = "24"

PulseAudio may need 32 bit processing to work with other Supported Audio Formats

There is a post on Arch forum from 6 years ago that also identified a similar anomaly
Pulseaudio with USB DAC (FiiO X3 II), DAC reports wrong sample rate - Arch Linux Forums
IMO the best response from that discussion (that was not investigated further) was

only a few drivers use/support S24_LE or S24_3LE

It might be possible to find the hardware sample-format with this command for USB

cat /proc/asound/*/stream0

and this for S/PDIF output from onboard audio

cat /proc/asound/*/pcm*p/sub*/hw_params

(this depth of information is not usually needed for general audio troubleshooting so you might need to look in other files in /proc/asound/ )

Previously 16 bit files played at 16 bits, 24 at 24 bit

You can probably get PulseAudio back to that behaviour if you revert to default configuration setting – default-sample-format s16le

I have setup the bit depth of pulseaudio to s24le, but pacmd list-sinks reports s32le.

Same behaviour like your machines.