Age of Empires 2 Definitive edition crashing on Nvidia GeForce GT1030

Hi all,

I’ve been struggling to get Age of Empires II Definitive Edition to work smoothly on Steam with my GeForce GT1030 graphics card. I’ve tried various command line arguments with Proton Experimental including prime-run, PROTON_USE_WINED3D11 and so on to no avail.

One particular trigger that causes it to crash in the game weirdly is when I advance to a new age. The system locks up with the screen frozen (the screen still renders) and I have to reboot the computer to regain control. It works pretty well up until this point.

Other system information:
CPU: Intel(R) Core™ i5-7400 CPU @ 3.00GHz
Driver version: 470.141.03
Kernel version: 5.18.17-1-MANJARO
Desktop environment: KDE Plasma

I’m just wondering if anyone has any ideas?

The steam logs with parameters prime-run %command% are here.
The steam logs with parameters PROTON_USE_WINED3D11=1 %command% are here.

EDIT: This fails in the exact same way with the 515 driver.

Hi, some questions in the first place:
What happens, if you do not use any parameters? Which Proton version are you on? Did you already try a custom Proton version by glorious eggroll (Proton GE)?
The prime-run command is for laptops with Intel/Nvidia hybrid graphics (Optimus). You seem to have a desktop pc. Why did you use it?

No parameters makes the game more sluggish. It still crashes at the same point. The WINED3D11 param is pretty smooth until I advance to the next age and locks up.

I tried prime-run because my PC has an Intel integrated graphics and a PCI express card. It may have been a shot in the dark.

Which graphics is used? If your Nvidia card is active all the time and onboard graphics is disabled (look in BIOS/UEFI settings) prime-run is not necessary.

Probably you should try: Releases · GloriousEggroll/proton-ge-custom · GitHub

Bios on the Lenovo PC uses the PCI Express. There’s three settings auto / integrated and PCI Express. It isn’t possible to use both simultaneously.

What does the proton custom do that’s different to the regular one? I’ll give it a try.

You only can use one graphics device at a time. I would recommend that you stay with Nvidia only if you play games for a good amount of your time. For office use and development you would be better off with the intel graphics.
But switching graphics on the fly / automatically is a mess on Linux.
Your Nvidia card is low end and more for office use. Older games should work, but it is in no case a gaming beast.

Proton GE is widely used by Linux gamers. Its programmer has a lot of experience and fixes problems much faster than mainline proton. And it is more stable than proton experimental and contains some nifty optimizations. So maybe it helps you to avoid your issues.

It failed in exactly the same way, which makes me wonder if it is a graphics driver issue rather than a Proton issue.

The logs are here from using the Proton GE. I still had the PROTON_USE_WINED3D11 flag enabled.

Use PROTON_USE_WINED3D instead. The other command is deprecated.

As a guess you could try with dxvk >= 1.10 or overriding d3dcompiler_* with winetricks.