Again issues with HP Laser cp1025nw

Hi all,

after i fixed the problems with the cp1025nw some weeks ago i now have the problem after a fresh install of Manjaro on my wifes notebook.

This was my previous thread where system-config-printer fixed the issue:

Now i tried exactly the same on the laptop of my wife.
Printer is installed, all settings are exactly the same as on my device. We checked every dialog.

But the printer does not work. The queue is accepting the print job and finishes it with
Idle - waiting for completion”, but it never completes the job.

Any ideas would be appreciated. If my wife can’t print - nothing to eat for me :slight_smile:

In most cases it is a connection issue.

Cups actually has sent the data and idle while waiting until the printer send an “all good” message.

Maybe try to restart cups and try again:

sudo systemctl restart cups
1 Like


It was not a connection problem. I ran hp-setup installed the plugin - performed a test page and it was working now.

But thanks for your fast reply.
i love Manjaro and especially this support forum :slight_smile:

Can you explain that further? Normally there is no “plugin” needed.

That was my thought as well.

I did some check in logs and identified an error regarding hplib Plugin
So i was running HP-Setup, let the setup tool download the plugin and install it.

Opened the printer setup page again, ran a test page and it worked.
No reboot, not removing or adding printer again in between.

Sometimes it’s better not asking why something is working :rofl:
Maybe it worked now by chance and i only assume it was fixed by the plugin.

Look, this forum is public and people search the web. Wouldn’t it be nice to have a nailed problem? Instead we see just “it magically works”. The next one who finds this conversation ask:

Why, how? What have you done @volkskamera? (While smashing the head on his keyboard)

If you do that in private then it is okay, but the whole thread becomes useless for the public. Do you see the problem?

However it works for you and nobody will ever know what your problem was actually.

1 Like

Valid point. Agreed.

So what i did are the following steps:

  • Installed Manjaro via USB from a fresh download. Device is an HP Elitebook 820 G1 (almost 8 years old)
  • The printer is via LAN attached in the same subnet as all my devices.
  • After the full installation including upgrades/updates of Manjaro, i used the system-config-printer as mentioned by you in the previous thread.
  • The printer was detected and identified as Jetdirect on port 9100
  • A test page did not work - print job was accepted, but it always got stuck at the final step.
  • After that i used HP-Setup to update the hplib plugin. Printer was not detected by the tool, but this was also the case of my previous installation
  • went back to the printer setup and then the test page appeared after firing a new job.

What i can’t answer is the question if the HP-Setup routine restarted the cups service. So i do not have evidence if the HP-Setup did the job or any other task in the background.

Hope that helps.