After wake up from suspend or hibernate i can see the desktop from before

some annoying security problem here: After wake up from suspend or hibernate i can see the desktop from before for ca. 1 sec. Then comes the fadeout-effect and then lock screen. I assume the fadeout-effect must be before suspend/hibernate and not after resume.
This is not just nasty but a real security issue. How can i get a rid of it?

My config files:




SuspendState=mem standby freeze
HibernateMode=platform shutdown
HybridSleepMode=suspend platform shutdown


org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type: ‘hibernate’
org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type: ‘suspend’
org.gnome.settings-daemon.plugins.power power-button-action: ‘interactive’
org.gnome.desktop.lockdown disable-lock-screen: false

my system:

OS: Manjaro 21.1.0 Pahvo
Kernel: x86_64 Linux 5.10.56-1-MANJARO
DE: GNOME 40.0
WM: Mutter
CPU: Intel Core i5-8265U
GPU: UHD Graphics 620 + NVIDIA GeForce MX230
GPU-Driver: video-hybrid-intel-nvidia-driver

nvidia packages:

lib32-libvdpau 1.4-1
lib32-nvidia-utils 470.57.02-1
libvdpau 1.4-1
linux510-nvidia 470.57.02-5 (linux510-extramodules)
mhwd-nvidia 470.57.02-1
mhwd-nvidia-390xx 390.144-1
nvidia-dkms 470.57.02-1
nvidia-prime 1.0-4
nvidia-utils 470.57.02-1


i have the same thing on KDE when waking from sleep.

1 Like

Can not confirm. I had old installation from last year steady updated to last month (to GNOME 40.0, trough GNOME 3.38). I didn’t had this effect.

Now i have a fresh installation and have this.

Probably some settings from past was taken through update routines and “saved” the right behavior of this transition effect?

I have investigated a little…
Now i believe the problem is not in GNOME or KDE but in systemd loginctl module.
If i start from the terminal the command:

$ loginctl lock-session

so i can see the same behavior:

  1. The screen gets dark
    1.1. (at this point the system goes to suspend/hibernate mode, i guess)
  2. The screen shows the last desktop for ca. 1 sec
  3. The lock screen is appears

The hotkey Super+L doesn’t show this behavior.

It is possible to add a hook to the sleep routines of systemd (see /usr/lib/systemd/sleep) but which command is fired on Super+L hotkey?

1 Like

Repaired from alone after some updates. I have just noticed the right behavior now. But i have no explanation.

Don’t know regarding GNOME, but this is a long-standing bug on KDE. 316734 – The desktop gets displayed for couple seconds after waking the system.

1 Like