After upgrade to GNOME 45 graphics operations are very slow


I have an ASUS ZenBook UX363, with Manjaro GNOME running on wayland and everything was fine and smooth until the update to GNOME 45 (2023-11-6).

I’ve tried numerous times after each stable update announcement. Disabled and deleted all extensions (needed to update gnome 44 → 45) before the update, refreshed mirrors and run sudo pacman -Syu.

After each update attempt after restart the system becomes sluggish. Videos I played before, I can not play after. The sound is playing, but the video window takes long to show and when showed, it is dropping nearly all frames. Even just opening terminal window animation is not fluent and takes a significant more time. It seems, that all HW video acceleration is not working.

I’m using 6.1 kernel currently, and tried the 6.6, but it didn’t help.

Gladly I’m using btrfs+timeshift, so I’m back to the last update with GNOME 44, on which everything is smooth & fast.

Does anybody has the same experience with graphics speed after upgrade? Any ideas what should I check, poke and fix to be fast after upgrade, as before?


inxi -Fazy
Might be a start.

1 Like

Here is the output of inxi -Fazy on the device before upgrade to GNOME 45:

$ inxi -Fazy
  Kernel: 6.1.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.1-x86_64
    root=UUID=b11608a3-541b-430c-aa1c-a53f3e5ff125 rw rootflags=subvol=@ quiet
    splash udev.log_priority=3
  Desktop: GNOME v: 44.5 tk: GTK v: 3.24.38 wm: gnome-shell dm: GDM v: 44.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: ASUSTeK product: ZenBook UX363JA_UX363JA v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: UX363JA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: UX363JA.303 date: 01/27/2021
  ID-1: BAT0 charge: 53.0 Wh (89.4%) condition: 59.3/67.3 Wh (88.2%)
    volts: 15.9 min: 15.9 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 25
  Device-1: hid-0018:04F3:2BB1.0001-battery model: ELAN9008:00 04F3:2BB1
    serial: N/A charge: N/A status: N/A
  Info: model: Intel Core i5-1035G4 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 note: check built: 2019-21 process: Intel 10nm
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xBC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 919 high: 1073 min/max: 400/3700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1017 2: 1005 3: 1002
    4: 931 5: 953 6: 400 7: 1073 8: 971 bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G4 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:8a5a class-ID: 0300
  Device-2: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-5:2 chip-ID: 13d3:56eb
    class-ID: fe01 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.2.1
    compositor: gnome-shell driver: X: loaded: intel dri: i965 gpu: i915
    display-ID: 0
  Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris wayland:
    drv: iris x11: drv: iris
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Iris Plus Graphics (ICL
    GT1.5) device-ID: 8086:8a5a memory: 7.28 GiB unified: yes display-ID: :0.0
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  API: ALSA v: k6.1.55-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off with: 1: a2jmidid status: off 2: nsmd
    status: off tools: jack_control,qjackctl
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 4 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 241.33 GiB (50.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLQ512HALU-00000
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: FXV7000Q temp: 24.9 C
    scheme: GPT
  ID-1: / raw-size: 97.66 GiB size: 97.66 GiB (100.00%) used: 75.41 GiB (77.2%)
    fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 42.2 MiB (16.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 318.56 GiB size: 318.56 GiB (100.00%)
    used: 165.42 GiB (51.9%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-4: /var/log raw-size: 97.66 GiB size: 97.66 GiB (100.00%)
    used: 75.41 GiB (77.2%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 1 (default 60) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 10.74 GiB used: 469.2 MiB (4.3%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
  Src: /sys System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (rpm): cpu: 2700
  Processes: 321 Uptime: 4h 58m wakeups: 7623 Memory: total: 8 GiB note: est.
  available: 7.46 GiB used: 5.32 GiB (71.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 2327 pm: pacman pkgs: 2277 libs: 506
  tools: gnome-software,pamac,yay pm: flatpak pkgs: 36 pm: snap pkgs: 14
  Shell: Zsh v: 5.9 running-in: tilix inxi: 3.3.30

Do I need to post the output of the command after the update, when I experience the issues?

Not necessarily. Though some logs from there might end up being needed.
This is just a good starting point for general system info.

(see if you have swap, filled partitions, weird boot options, etc)

Looks like you might have a BIOS update, but it appears unlikely to be related (“intel security”).

And root is getting full, but its not quite in danger yet.

If you need these extra software sources, maybe see if you can live with just one. This will reduce some overhead. If you ask me its an easy choice to ditch snap.

Sorry none of those things are likely related to your problem … just some observations and thoughts.

I’m also not that familiar with gnome, but others here are and I’m sure we’ll get some other opinions soon.

But you should really be careful with btrfs once you get above 80%.


@andreas85 @cscs Thanks for your concerns about my btrfs state. I’ve read about it, I’m checking it from time to time and begun writing some scripts to notify, etc.

Also thanks for the BIOS update info, will check it and try to update, even if it is not related to my problem.

I’ve collected outputs for glxinfo before and after update. Maybe it helps.
It was too long to paste here, so I created a gist, there are 2 files. Manjaro glxinfo before and after upgrade to GNOME 45 · GitHub

What other kind of logs should I provide?

Today I tried [Stable Update] 2023-12-01, with the new LTS kernel (6.6.x) too, but with the same outcome. Everything related to graphics is slow and laggy.

I’m back to [Stable Update] 2023-10-13. :frowning:

It might be worth a try to create a new user account and check if the issue remains. That way you can rule out any user configuration changes.

Thanks. You might be into something. I created a new user (admin), then updated through the new user and it seemed, that there was no issue with the graphics. But than something came along (some other issue), I had to revert back to the previous (GNOME 45) configuration. So I will try again later and post the results.

Meanwhile, what config in user home space could make the graphics worse? Or is there some config in /etc special for a user? Any Idea?

If it only affects one user then it would be something in HOME … maybe ~/.config/

I’ve tried once again (more times), but this time it didn’t work. I even somehow couldn’t login.

What I’ve done. For my current user I disabled autologin, disabled extensions and removed everything from ~/.local/share/gnome-shell/extensions just to be sure. Than I’ve created a new user testuser (an admin account) and switched to the new user. I disabled extensions for the testuser. Made an update via pacman and after reboot I couldn’t login nether to testuser nor to my account. After filling password the screen changed as if starting GNOME and then it reverted back to login. I figured out, I can login via GNOME on X11 and after reexamining journalctl -b I found out, there is a crash & core dump after logging to GNOME Wayland. From that I deduced, that it is not the config in my home directory.

So I tried another approach. I created a Live USB from latest image in manjaro downloads. After booting the image I figured out, that it is still with GNOME 44. So I made another, this time an actual image, using these instructions for building Manjaro ISOs with buildiso (or these). When booting from this latest image, the GNOME Wayland starts without problems and everything seems to work.

So I’m going for the easiest path (for me). Instead of figuring out, what is the cause of the crashes, I’ll reinstall manjaro from scratch. I’ll inform you (in this thread) of the outcome and mark this as solved when I succeed.

Thanks for all suggestions, I hope this is my last post in this thread.
Have nice winter holidays and I wish you all a happy new year.

I’m here again. This is the last time.

I had a little troubles, installing Manjaro using the buidiso method, cause mkinitcpio failed during install, so I couldn’t install it. As last resort, I downloaded last official image from Manjaro downloads page and successfully installed Manjaro GNOME 44. But after update to latest packages, which included update to GNOME 45, the wayland session was crashing again. But this time when logged to XOrg session, there was no graphics lagging and I was able to play videos smoothly. So I was somehow satisfied.

But not fully satisfied and didn’t stop to search for a solution to run a wayland session. After a few days searching I stumbled across this post on asubuntu, which referred to a issue on gardualinux forum where a solution was marked.

i fixed it . i deleted every extension i had installed , then deleted the dconf folder in ./config , it did the trick for me.

So I tried it, I deleted (& backed up) every extension in /usr/share/gnome-shell/extensions and ~/.local/share/gnome-shell/extensions and deleted the ~/.config/dconf folder and rebooted. On the gdm I selected the Gnome (wayland) session, logged in and couldn’t believe my eyes, wayland didn’t crash and everything is working.

Thanks everybody for your replies, I hope this helps someone.

I’m back, cause I found out, that after logout or restart, I’m no longer able to log in to wayland again. The solution is to delete the ~/.config/dconf/user file. After that wayland session no longer crashes and works. It’s strange. The extensions are no longer a problem (maybe they weren’t part of the problem from the start).

So, when I reboot (or logout) and I’m unable to start wayland cause it crashes and goes back to login screen, I login to tty2, export current dconf dconf dump / > ~/dconf.dump, remove the user file rm ~/.config/dconf/user and after a successful login I bring back the dconf dconf load / < ~/dconf.dump.

I’m not going to remove a solution mark from this thread, cause I found a fix for the laggy graphics operations, but I will make a new thread for this dconf issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.