After upgrade, right after boot I get a blank screen and no login page

I have Manjaro with KDE on my desktop PC, which has an AMD Ryzen CPU and and ATI Radeon GPU.

After a big update yesterday (some 2.8 GB of download), there is no more graphical appearance after the boot. As a matter of fact, it simply gets stuck on a blank screen after I select Manjaro in GRUB, and I can’t get in any non graphic session either (e.g. with Ctrl+Alt+F4 or similar). :man_shrugging:

I’m fairly sure that the hardware is not the issue here because I have Windows 10 in dual bootm GRUB still seems in good order, and if I boot into Windows everything works flawlessly. I also tried some heavy gaming for the GPU, some HW check and so.

Also, I’ve already tried all sort of things, I’ll try to go through them all, at least the significant ones.
I’ve already read anything I could find here on the forum, and also elsewhere, mostly from this page and through this search.

Let’s start from detailed sympthoms.
The GRUB seems all good, all familair options there, Windows can be booted alright, as said just above. If I select Manjaro (any flavour of it, any available kernel, failsafe or not), the behavior is identical: right after it gets out of GRUB, the screen turn black (nothing, not even a small cursor top left) and stays like that indefinitely. There is a signal out of the graphic card, connected with DP, because the monitor doesn’t complain about absence of input signal and doesn’t go into stand-by. The backlight of the monitor seems on as well.

This is what I’ve already tried, mostly through ssh-ing into the machine (yes, it seems it is running):

  • uninstalling and reinstalling graphic drivers
sudo mhwd --remove pci video-linux

and then

sudo mhwd --install pci video-linux

and similar attempts; drivers got uninstalled and reinstalled but nothing changed
– on this same topic, I’ve never noticed before, but… why not only packages for AMD are installed, but also everthing for NVIDIA and Intel GPUs? Is there a way to install only stuff for AMD? Is it not recommended?

  • various attempts at updating the entire system, for instance with:
sudo pacman -Syyu

and other variations on the theme: there was never anything to update, actually, so not a big help

  • all options I found in GRUB :control_knobs:
    – the various kernels and with failsafe modes: exactly same behaviour as described
    – the btrfs snapshots: I took the farthest away, it shows the exact same behaviour, even if the snapshot date is one day before it stopped working… and I know the snapshot is “from that past” because if I try to pamac upgrade... then I see all the updates that broke the thing; quite a mistery that it doesn’t run even like this… no?
  • updated GRUB, nothing new, nothing fixed… :astonished:

The interesting thing is, it seems that the system is running, except not presenting any graphical feature.
I know this because I can actually ssh into the machine, as said right above, and everything seems perfect.
This is actually the way I could try most of the stuff mentioned above, without success thus far.
In brief, why I think the system is OK underneath:

  • systemd seems to be running fine, first of all because the ssh server runs as a systemd service
    – also, all my network drives, mounted with systemd user services, are mounted correctly
  • I can actually use cuda features in pytorch, and the device is listed correctly, so it seems the AMDGPU drivers are still there and running OK-ish?
❯ mamba activate torchenv
❯ python
Python 3.8.18 | packaged by conda-forge | (default, Oct 10 2023, 15:44:36) 
[GCC 12.3.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import torch
>>> torch.cuda.is_available()
>>> torch.cuda.get_device_name()
'AMD Radeon RX 6700 XT'

I’d really appreciate any hint at what to try next… I’m quite at a loss… The system is there but doesn’t want to use the monitor :smiley:

I haven’t gone as deep as you, but believe I’ve having the same issue. After doing the all the updates yesterday and rebooted my computer would go to Grub no problem, but then just blank black screen after that. I haven’t done anything to confirm that things are actually running while the screen is black. My hardware is very different than yours.
Kernel: 6.6.10-1-MANJARO
Uptime: 7 mins
Packages: 1928 (pacman), 12 (flatpack)
Shell: bash 5.2.21
Resolution: 1080x1920, 1920x1080, 1920x1080
DE: Plasma 5.27.10
WM: KWin
Theme: [Plasma], Breeze [GTK2/3]
Icons: [Plasma], breeze [GTK2/3]
Terminal: yakuake
CPU: Intel i7-10700F (16) @ 4.800GHz
Memory: 6651MiB / 64171MiB

At first I was able to load the snapshots right before the updates, but now I’m not able to (I think it said that it failed to load the microcode, but I’m not 100% sure and don’t want to reboot again right now to see it). So now I’m on my daily BTRFS Timeshift snapshot from the 20th. I just removed almost all my AUR packages in case they caused a problem and was going to consider switching to the 6.7 kernel to see if I get any difference.
I’m not experienced enough with the logs to feel like diving through those quite yet to see if I can find the issue in there, but may attempt that if others want to offer some steps or things to search for.

Ok, after even more fiddling today, I believe I found the solution. At least… now it’s working again :tada:.

The issue seems all to be due to plymouth, that little piece of… software that runs right after GRUB, just before the login manager, that shows a splash screen with some moving thing in it… :unamused:

So, I got the hint because after trying another run of update with pamac:

❯ sudo pamac upgrade --force-refresh
[sudo] password for bill: 
Synchronizing package databases...
Refreshing core.db...                                                                                                                                    
Refreshing extra.db...                                                                                                                                   
Refreshing multilib.db...                                                                                                                                
Refreshing core.files...                                                                                                                                 
Refreshing extra.files...                                                                                                                                
Refreshing multilib.files...                                                                                                                             
Warning: plymouth: local (24.004.60-6) is newer than extra (22.02.122-16.3)                                                                              
Resolving dependencies...
Checking inter-conflicts...

To upgrade (1):
  thunderbird  115.8.0-1  (115.7.0-2)  extra  58.0 MB

Total download size: 58.0 MB
Total installed size: -10.3 MB

Apply transaction ? [y/N] n

You see that warning that plymouth seems to have travelled ahead in space-time? :timer_clock: :zap:

Well, I’ve then simply run pamac again, allowing for downgrades, et voilá:

❯ sudo pamac upgrade --force-refresh --enable-downgrade
[sudo] password for bill: 
Synchronizing package databases...
Refreshing core.db...                                                                                                                                    
Refreshing extra.db...                                                                                                                                   
Refreshing multilib.db...                                                                                                                                
Refreshing core.files...                                                                                                                                 
Refreshing extra.files...                                                                                                                                
Refreshing multilib.files...                                                                                                                             
Warning: plymouth: downgrading from version 24.004.60-6 to version 22.02.122-16.3                                                                        
Resolving dependencies...
Checking inter-conflicts...

To upgrade (1):
  thunderbird  115.8.0-1       (115.7.0-2)    extra  58.0 MB
To downgrade (1):
  plymouth     22.02.122-16.3  (24.004.60-6)  extra  1.0 MB

Total download size: 59.0 MB
Total installed size: -10.6 MB

Apply transaction ? [y/N] y

As simple as that, plymouth was restored to the current universe and everything worked again as if nothing has happened…

I’m not super amused at how this thing went down, to be honest… :roll_eyes:

1 Like

Adding a post that can be marked as solution, with one simple command:

sudo pamac upgrade --force-refresh --enable-downgrade

Full description right above.

1 Like

That appeared to work for me, but now my Grub doesn’t appear to be pointing to the right one. So the new snapshots created aren’t appearing in the snapshot list in Grub, the primary boot still has the issue, but the snapshot I had booted from before and ran the command you posted still works and is now up to date. So more work for me!


Just to close the circle on this, I tried reinstalling and updating my grub, but it said it wasn’t using the entries by default and grub remained the same. Found another post with other sort of grub issues, but it had the resolution for my grub.

I dont know why its so apparently confusing.

I suppose it stands to reason that you didnt notice the update announcement thread or the dozen+ duplicate threads all pointing at plymouth?

And the follow-up posts that then indicated plymouth was downgraded due to these issues.

And further additions to the update announcement thread pointing out the available downgrade for those affected by the performance of the plymouth update.

Or you know … you can just disable/remove plymouth.

I can’t speak for anybody else, but no I did not see any of that. I don’t know if it was my timing or what, but I didn’t see any of those until today.
After I got the issue I booted into my Windows drive and went to the Announcements section of the forum and it didn’t even show me the post for the 2/21 update, only the previous ones. I hadn’t yet determined it was Plymouth, and frankly didn’t bother to troubleshoot until today when I saw that @billznn had posted this thread. I saw this thread before any of the others and just went with it.
So I’m not sure why I couldn’t see the announcement post yesterday around this time, but if I had then I probably would have then looked for and found your post. shrug

Alls well I guess. :slight_smile:
Mostly I wanted to communicate that ‘plymouth was in a time warp’ was not as chaotic as it apparently seemed here. It was updated. Lots of breakage. The version in the repos was downgraded. Users then see downgraded package.
No timey-wimey stuff really, just repo mechanics.

Well, I assume that is really subjective. If my PC gets stuck into a blank screen, with no other option than hard shutdown, it looks pretty bad to me.
If I wasn’t a computer savvy, if I didn’t have ssh sever enabled on my machine, if I didn’t have another machine with which to try ssh-ing into the broken machine… and you can go on with this a bit, how could one even know that plymouth was then downgraded? Or even, how could one even run another fixing upgrade from a stuck blank screen? :crystal_ball:

So, I agree that for an experienced Linux user (with plenty of experience in troubleshooting this sort of stuff), it may have not been a big deal… but for the majority of users approaching Manjaro as a self-advertised stable release (like, commercial grade), believe me it was.
Also, it was not automatically fixed by another update, because the option --enable-downgrade in pamac is not by default, and one needs to come up with that idea (ok, there is a warining that may hint at that).

Yeah, absolutely… it was an ironic metaphor :laughing:

1 Like

The last updates which arrived evening of 21st resulted in the blank screen you describe (Manjaro KDE plasma). I was a bit stuck as I did not have an installer with me on usb stick to fix by booting from the stick. What I did find a bit by trial and error was removing “splash” from the grub commands avoids the Plymouth animation and so boot was restored. We can live without this animation. Some may disable this permanently. “quiet” can normally be toggled by use of the Esc key. A rapid bug fix to Plymouth was issued on the 22nd which has fixed this. Looks like testing was missed before release of the first update!

1 Like

I wonder how many other features like this one (plymouth animation) would be better to disable because they don’t add much but carry a big risk… but they are enabled by default.
So, in a way, this breaks a bit the perception that this distro is reliable…

I’m perfectly ok with this, I’m not complaining. I’ve been using Linux since the mid '90s :rofl: But I had the idea that Manjaro wanted to target an audience of non-exclusively hacky users, right? So I wonder if we can help the developers and maintainers in any way possible.

I don’t know what would be the best place to give this sort of feedback (e.g. plymouth has a risk/benefit ratio quite high, so better disable it by default”, that has pretty much been the thing I’ve been reading about this recent issue in all topics it was discussed).
It’s kinda clear to me that the solution would be then to disable it by default in the distro?

If this forum is the best place for giving this feedback,. than it’s perfect. Otherwise, I’d be willing to help more in communicating.

1 Like

Well … that has nothing to do with its version being newer or older.

And as with any other scenario where gfx/boot didnt work you might use something like

I might even say that if one cares about such things … they should probably not use plymouth.

Again … my comments were to help you better understand what happened in accordance with the versioning. Because that seemed to be a source of confusion.

If you had simply not updated at the time you did … but ~24 hours later you would have never seen these different versions, or the blackscreen for that matter. Same goes for not having plymouth :wink:

1 Like