After update printer Brother MFC-J4620DW prints white as gray

I’m on testing branch. Some recent updates (it could be a couple of weeks) messed up printing for good. Meaning, EVERY WHITE SPACE IS PRINTED AS A DARK GRAY. Since most of the document’s surface is white, I get dark gray, almost graphite papers, which are useless. Moreover, it uses up a lot of ink.

Here is photo of an example how it looks like. Mind you, in reality, the gray is MUCH DARKER than on the photo.

The drivers are from AUR: brother-mfc-j4620dw 3.0.1-1

What I already tried:

  1. I tried various color settings - none of them made any difference.
  2. Printing various document formats - no matter if this is pdf, xlsx, odt - the issue happens everywhere
  3. I logged in into my testing, vanilla user, the printing issue happens there as well, so this isn’t a matter of user configs
  4. Reinstalled drivers, rebooted - still the same.
  5. I printed out those documents on Windows, it printed correctly - this proves that the problem is with software, not hardware.
  6. Set up printer once again, both in CUPS and driverless mode, issue persists
  7. Printer restart - didn’t help.
  8. Downgraded and rebooted: cups, libcups, lib32-libcups, linux-firmware - still nothing, the issue persists.

Since I use my laptop for work and I need printing from time to time, this is a major issue that has to be solved.

What could have caused it and how to solve it?

Thank you

Michał Dybczak

Can you setup the printing driver again ?

I tried it, every time I chose defaults, and it’s the same result, no matter if I choose CUPS or driverless option. What does it tell us?

P.S. Test site prints correctly, normal documents are not.

Which packages could influence printing?

EDIT: I downgraded and rebooted: cups, libcups, lib32-libcups, linux-firmware - still nothing, the issue persists :frowning:

I use the printer Brother MFC too, but I have no issue.
Maybe LibreOffice is the issue.
Try save text/document in PDF, then you print this PDF, does it work?

No, the issue is the same with pdf’s, however, I just noticed, that PDF previews show up dark, just like it is on print. This is suspicious and can’t be a coincidence.

So to sum up:

A documented opened up is shown correctly. Print preview is shown also correctly. Print makes white into dark gray. Dolphin preview of a PDF files also shows this dark gray instead of white.

This may be not a printer issue, or not a direct printer issue.

I agree. It seems something is wrong in your custom KDE system.

And on top of that, it’s not a problem with the user, because on a generic, test user the issue still persists. So this may go deeper. We are a step closer.

EDIT: Nautilus also shows this dark preview, so this may not be even KDE thing.

LibreOffice saved the PDF but it shows gray, right?

Did you check other white PDF that was not saved by LibreOffice?

I don’t think that LO is the problem here. One of the PDF documents was PDF from the start and was created on Windows 2 years ago (no idea how). I’ll try to create PDF in other app and see what’s happens thou.

EDIT: Some PDFs from the web, are printing correctly. This is confusing. If this was only a pdf issue, but no, other formats also suffer from this, but maybe LO is someone adding to it? Hm… Need to make some tests.

Which version are you running. LibreOffice got a update today in testing branch:

Also see this:

1 Like

I just updated the system and… it may be fixed. Now when I’m opening any documents in LO and saving it as PDF show correct preview (while old ones are still grayed).

Yay! Other formats now print correctly! So the today’s update fixed it!