After update I can no longer boot

After update I can no longer boot, I have encrypted drive using LUKS and after I provide the password I see Slot 0 opened but then I end up in emegrency shell with following errors:

ERROR: device 'UUID=1234-abcd' not found. Skipping fsck.
mount: /new_root: can't find UUID=1234-abcd
You are now being dropped into emegrency shell
sh: can't access tty: job control turned off
[rootfs ]#

Udate1 : I wanted to try manually to mount it but I can’t find cryptsetup in the initramfs, could that be the issue?
lsmod shows no dm_crypt module, I guess now I know why it is not working but how can I fix it?

I tried to add back the encrypt in mkinitcpio using the manjaro-chroot approach and now I have dm_crypt module and cryptsetup so in the initramfs shell I can manually mount but still getting the same error. Does anybody know what args need to be passed to systemd if I try manually to switch_root.

I don’t have time to figure it out so reinstalled the machine and recovering from backup …

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.