After update driver issues, possibly?

After updating, I get the persistent “Starting version 249.6-3-manjaro” message and nothing further. Some searching seems to indicate this could be video driver related.

My graphics card is a GTX760.

mhwd -li shows the installed configs as:

video-hybrid-amd-nvidia-prime (and)

Those drivers weren’t specifically listed as one of the problem causing versions, at least I didn’t see them listed.

I tried to install video-hybrid-amd-nvidia-470xx-prime and it conflicts with the current driver, thus it won’t install. Trying to remove the current driver fails due to it being a dependency of cuda.

What should I do?

  1. force the install of the new driver
  2. remove cuda, remove the old driver, install the new one then reinstall cuda
  3. leave it alone because it isn’t the cause of XFCE failing to start anyhow

If I’m barking up the wrong tree and it’s #3, what should my course of action be?

To test if the idea of having a too-new nvidia driver is correct, yes #2.
Remove current, install other series (video-hybrid-amd-nvidia-470xx-prime).

I just tried to uninstall cuda so I could attempt the driver change, but there are 2 packages that depend on it being installed: magma and popsift-libs. Both of those are dependencies of of other packages.

Should I switch to option 1 and try to force install the new driver, or am I going to break something else?

I got cuda and the old driver uninstalled, but the new driver installation fails with a conflicting files error, showing 12 files for lib32-nvidia-470xx-utils as already existing in the filesystem. Pacman -Q gives me “package not found.”

Is it a bad idea to manually remove the files and try the driver install again, or am I missing something here?

You can manually remove them yes, as they will of course be created by the installation.

Thank you. I was kind of assuming I could remove them, but I’ve really screwed myself by making assumptions in the past.

Anyhow, that worked and it seems like everything is back to normal now. I appreciate your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.