After Update, Dolphin shows unmount button on my Internal Partition

How do i prevent this unmount button to show up, on my Internal Drives?
I mounted this drive with Fstab btw.

I have a bad feeling that i sooner or later just missclick on this button.

For external drives okay, but i have no clue why KDE changes this behaviour in the new Dolphin version. I really dislike this button.

Is hardcoded and can’t be disabled. Will show on all devices/mountpoints except the root /
You can hide it tho, so no missclick after that.


1 Like

Would be nice, to have a way to prevent a drive from unmount.
I hide alot partitions in Dolphin already, but i also want to see the free space bar (overview) on the left side in Dolphin.

If i hide my Partition, i also can’t select it to browse inside… or i have to always unhide it.

Is there a usefull way to complain about this downgrade in KDE Forum? Im have a feeling i just will get ignored anyways :confused:

@Kobold As always there are multiple solutions:

  • Free space is also displayed in the lower right of Dolphin
  • You can create a new folder in ‘Places’ to access root directories and you can then hide the disk entry.

Just for fun I clicked on the dismount button in Dolphin and it gives an error:

So looks like it’s clever enough and won’t allow dismounting.
I don’t recommend to try this unless you know how to fix it in case your system behaves differently.

1 Like

I always had this feature disable, because i dont needed that in the past. I just reverted this setting and the Free Space Info/display is just buggy and shows zero information.

@Kobold There are other tools then for more disk information, e.g filelight, Kdiskfree and many more. A klick on the disk info bar at the lower right gives you more options to scan.

E.g Kdiskfree (kdf) provides a new System Settings menu ‘Storage Devices’:

1 Like

That’s hiding the device which is find if you add the device or some of the subfolder from trhat device to Places first.