After Trying to Install AMD ati GPU, stuck on black screen after boot

After Trying to Install AMD ati GPU, stuck on black screen after booting, in my Toshiba a300 laptop.

The lightdm is not running its falling at boot and I think the driver installation broke something, I don’t want the AMD GPU driver any more I just want my pc working normal on video-linux default VGA driver like before, so I used chroot and I uninstalled the AMD driver and Updated the system with sudo pacman -Syuu and installed video-linux, but the problem is still the same, it dint change anything it is still stuck on black screen, I have not problem switching to tty.

Please help me I have done a lot of configuration on this Manjaro installation and it is my daily driver and I don’t have any system backup to restore from.

For the time being in the same PC I installed another instance of Manjaro and I am using it temporarily and it is working fine. But I need to get to my other instance of Manjaro whrere all my configurations are packages are there, I don’t want to reinstall I just want to fix the problem, please support.

Please find details below.

cat /etc/lsb-release


inxi -G

Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470] driver: N/A
           Device-2: Chicony USB 2.0 Camera type: USB driver: uvcvideo
           Display: server: 1.20.13 driver: loaded: N/A failed: fglrx tty: 144x54
           Message: Advanced graphics data unavailable in console. Try -G --display

lspci | grep VGA

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]

sudo systemctl status lightdm

× lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Fri 2021-11-05 06:28:39 +0530; 2min 46s ago
       Docs: man:lightdm(1)
    Process: 939 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
   Main PID: 939 (code=exited, status=1/FAILURE)
        CPU: 77ms

Nov 05 06:28:38 pc systemd[1]: lightdm.service: Main process exited, code=exited, status=1/FAILURE
Nov 05 06:28:38 pc systemd[1]: lightdm.service: Failed with result 'exit-code'.
Nov 05 06:28:39 pc systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Nov 05 06:28:39 pc systemd[1]: Stopped Light Display Manager.
Nov 05 06:28:39 pc systemd[1]: lightdm.service: Start request repeated too quickly.
Nov 05 06:28:39 pc systemd[1]: lightdm.service: Failed with result 'exit-code'.
Nov 05 06:28:39 pc systemd[1]: Failed to start Light Display Manager.


  UNIT                                                                                      LOAD   ACTIVE SUB       DESCRIPTION
  proc-sys-fs-binfmt_misc.automount                                                         loaded active running   Arbitrary Executable File Formats File System Automount Point
  sys-devices-pci0000:00-0000:00:01.0-0000:01:00.0-backlight-acpi_video0.device             loaded active plugged   /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/backlight/acpi_video0
  sys-devices-pci0000:00-0000:00:01.0-0000:01:00.1-sound-card1-controlC1.device             loaded active plugged   /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/controlC1
  sys-devices-pci0000:00-0000:00:1b.0-sound-card0-controlC0.device                          loaded active plugged   /sys/devices/pci0000:00/0000:00:1b.0/sound/card0/controlC0
  sys-devices-pci0000:00-0000:00:1c.0-0000:02:00.0-net-enp2s0.device                        loaded active plugged   RTL810xE PCI Express Fast Ethernet controller
  sys-devices-pci0000:00-0000:00:1c.1-0000:03:00.0-net-wlp3s0.device                        loaded active plugged   WiFi Link 5100 (AGN)
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda1.device  loaded active plugged   TOSHIBA_MK4058GSX WinRE
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda2.device  loaded active plugged   TOSHIBA_MK4058GSX Vista
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda3.device  loaded active plugged   TOSHIBA_MK4058GSX 3
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda4.device  loaded active plugged   TOSHIBA_MK4058GSX 4
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda5.device  loaded active plugged   TOSHIBA_MK4058GSX 5
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda6.device  loaded active plugged   TOSHIBA_MK4058GSX 6
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda7.device  loaded active plugged   TOSHIBA_MK4058GSX 7
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda-sda8.device  loaded active plugged   TOSHIBA_MK4058GSX Data
  sys-devices-pci0000:00-0000:00:1f.2-ata1-host0-target0:0:0-0:0:0:0-block-sda.device       loaded active plugged   TOSHIBA_MK4058GSX
  sys-devices-pci0000:00-0000:00:1f.2-ata6-host5-target5:0:0-5:0:0:0-block-sr0.device       loaded active plugged   MATSHITADVD-RAM_UJ880AS
  sys-devices-platform-serial8250-tty-ttyS0.device                                          loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS0
  sys-devices-platform-serial8250-tty-ttyS1.device                                          loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS1
  sys-devices-platform-serial8250-tty-ttyS2.device                                          loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS2
  sys-devices-platform-serial8250-tty-ttyS3.device                                          loaded active plugged   /sys/devices/platform/serial8250/tty/ttyS3
  sys-devices-virtual-misc-rfkill.device                                                    loaded active plugged   /sys/devices/virtual/misc/rfkill
  sys-module-configfs.device                                                                loaded active plugged   /sys/module/configfs
  sys-module-fuse.device                                                                    loaded active plugged   /sys/module/fuse
  sys-subsystem-net-devices-enp2s0.device                                                   loaded active plugged   RTL810xE PCI Express Fast Ethernet controller
  sys-subsystem-net-devices-wlp3s0.device                                                   loaded active plugged   WiFi Link 5100 (AGN)
  -.mount                                                                                   loaded active mounted   Root Mount
  dev-hugepages.mount                                                                       loaded active mounted   Huge Pages File System
  dev-mqueue.mount                                                                          loaded active mounted   POSIX Message Queue File System
  home.mount                                                                                loaded active mounted   /home
  proc-sys-fs-binfmt_misc.mount                                                             loaded active mounted   Arbitrary Executable File Formats File System
  run-user-1000.mount                                                                       loaded active mounted   /run/user/1000
  sys-fs-fuse-connections.mount                                                             loaded active mounted   FUSE Control File System
  sys-kernel-config.mount                                                                   loaded active mounted   Kernel Configuration File System
  sys-kernel-debug.mount                                                                    loaded active mounted   Kernel Debug File System
  sys-kernel-tracing.mount                                                                  loaded active mounted   Kernel Trace File System
  tmp.mount                                                                                 loaded active mounted   Temporary Directory /tmp
  systemd-ask-password-console.path                                                         loaded active waiting   Dispatch Password Requests to Console Directory Watch
  systemd-ask-password-wall.path                                                            loaded active waiting   Forward Password Requests to Wall Directory Watch
  init.scope                                                                                loaded active running   System and Service Manager
  session-1.scope                                                                           loaded active running   Session 1 of User saedee
  accounts-daemon.service                                                                   loaded active running   Accounts Service
  alsa-restore.service                                                                      loaded active exited    Save/Restore Sound Card State
  avahi-daemon.service                                                                      loaded active running   Avahi mDNS/DNS-SD Stack
  cronie.service                                                                            loaded active running   Periodic Command Scheduler
  dbus.service                                                                              loaded active running   D-Bus System Message Bus
  getty@tty2.service                                                                        loaded active running   Getty on tty2
  kmod-static-nodes.service                                                                 loaded active exited    Create List of Static Device Nodes
● lightdm.service                                                                           loaded failed failed    Light Display Manager
  lvm2-monitor.service                                                                      loaded active exited    Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
  ModemManager.service                                                                      loaded active running   Modem Manager
  NetworkManager.service                                                                    loaded active running   Network Manager
  polkit.service                                                                            loaded active running   Authorization Manager
  systemd-backlight@backlight:acpi_video0.service                                           loaded active exited    Load/Save Screen Backlight Brightness of backlight:acpi_video0
  systemd-binfmt.service                                                                    loaded active exited    Set Up Additional Binary Formats
  systemd-fsck@dev-disk-by\x2duuid-01659711\x2d05f3\x2d4901\x2da9ec\x2d61b2e517e31e.service loaded active exited    File System Check on /dev/disk/by-uuid/01659711-05f3-4901-a9ec-61b2e517e31e
  systemd-journal-flush.service                                                             loaded active exited    Flush Journal to Persistent Storage
  systemd-journald.service                                                                  loaded active running   Journal Service
  systemd-logind.service                                                                    loaded active running   User Login Management
  systemd-modules-load.service                                                              loaded active exited    Load Kernel Modules
  systemd-random-seed.service                                                               loaded active exited    Load/Save Random Seed
  systemd-remount-fs.service                                                                loaded active exited    Remount Root and Kernel File Systems
  systemd-sysctl.service                                                                    loaded active exited    Apply Kernel Variables
  systemd-tmpfiles-setup-dev.service                                                        loaded active exited    Create Static Device Nodes in /dev
  systemd-tmpfiles-setup.service                                                            loaded active exited    Create Volatile Files and Directories
  systemd-udev-trigger.service                                                              loaded active exited    Coldplug All udev Devices
  systemd-udevd.service                                                                     loaded active running   Rule-based Manager for Device Events and Files
  systemd-update-utmp.service                                                               loaded active exited    Record System Boot/Shutdown in UTMP
  systemd-user-sessions.service                                                             loaded active exited    Permit User Sessions
  tlp.service                                                                               loaded active exited    TLP system startup/shutdown
  ufw.service                                                                               loaded active exited    CLI Netfilter Manager
  user-runtime-dir@1000.service                                                             loaded active exited    User Runtime Directory /run/user/1000
  user@1000.service                                                                         loaded active running   User Manager for UID 1000
  wpa_supplicant.service                                                                    loaded active running   WPA supplicant
  -.slice                                                                                   loaded active active    Root Slice
  system-getty.slice                                                                        loaded active active    Slice /system/getty
  system-modprobe.slice                                                                     loaded active active    Slice /system/modprobe
  system-systemd\x2dbacklight.slice                                                         loaded active active    Slice /system/systemd-backlight
  system-systemd\x2dfsck.slice                                                              loaded active active    Slice /system/systemd-fsck
  system.slice                                                                              loaded active active    System Slice
  user-1000.slice                                                                           loaded active active    User Slice of UID 1000
  user.slice                                                                                loaded active active    User and Session Slice
  avahi-daemon.socket                                                                       loaded active running   Avahi mDNS/DNS-SD Stack Activation Socket
  dbus.socket                                                                               loaded active running   D-Bus System Message Bus Socket
  dm-event.socket                                                                           loaded active listening Device-mapper event daemon FIFOs
  lvm2-lvmpolld.socket                                                                      loaded active listening LVM2 poll daemon socket
  systemd-coredump.socket                                                                   loaded active listening Process Core Dump Socket
  systemd-journald-audit.socket                                                             loaded active running   Journal Audit Socket
  systemd-journald-dev-log.socket                                                           loaded active running   Journal Socket (/dev/log)
  systemd-journald.socket                                                                   loaded active running   Journal Socket
  systemd-rfkill.socket                                                                     loaded active listening Load/Save RF Kill Switch Status /dev/rfkill Watch
  systemd-udevd-control.socket                                                              loaded active running   udev Control Socket
  systemd-udevd-kernel.socket                                                               loaded active running   udev Kernel Socket
  dev-disk-by\x2duuid-dec858bb\x2db5c1\x2d4ec6\x2da4dd\x2d938985315a65.swap                 loaded active active    /dev/disk/by-uuid/dec858bb-b5c1-4ec6-a4dd-938985315a65                                                                              loaded active active    Basic System                                                                         loaded active active    Local Encrypted Volumes                                                                              loaded active active    Login Prompts                                                                          loaded active active    Graphical Interface                                                                       loaded active active    Preparation for Local File Systems                                                                           loaded active active    Local File Systems                                                                         loaded active active    Multi-User System                                                                            loaded active active    Network                                                                    loaded active active    User and Group Name Lookups                                                                              loaded active active    Path Units                                                                          loaded active active    Remote File Systems                                                                             loaded active active    Slice Units                                                                            loaded active active    Socket Units                                                                              loaded active active    Sound Card                                                                               loaded active active    Swaps                                                                            loaded active active    System Initialization                                                                             loaded active active    Timer Units                                                                        loaded active active    Local Verity Integrity Protected Volumes
  logrotate.timer                                                                           loaded active waiting   Daily rotation of log files
  man-db.timer                                                                              loaded active waiting   Daily man-db regeneration
  pamac-cleancache.timer                                                                    loaded active waiting   Monthly clean packages cache
  pamac-mirrorlist.timer                                                                    loaded active waiting   Generate mirrorlist weekly
  shadow.timer                                                                              loaded active waiting   Daily verification of password and group files
  systemd-tmpfiles-clean.timer                                                              loaded active waiting   Daily Cleanup of Temporary Directories
  updatedb.timer                                                                            loaded active waiting   Daily locate database update

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB    = The low-level unit activation state, values depend on unit type.
118 loaded units listed. Pass --all to see loaded but inactive units, too.
To show all installed unit files use 'systemctl list-unit-files'.

mhwd -li

#[1m#[31m> #[mInstalled PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

#[1m#[31mWarning: #[mNo installed USB configs!

I dont know what you did … but it appears you did it wrong.
Also … without some extra work, you cant ‘not use the amd driver’ … its opensource and in the kernel.
And I really dont think you want to be using VESA or some other ‘generic’.

Hm… by the above did you mean you tried to forcibly install Catalyst? If so … dont do that.

I guess I will leave the following in case your issue is as simple as booting and force reinstalling the drivers (probably after removing anything extra you did, and doing a full update - sudo pacman-mirrors -g && sudo pacman -Syyu)

[HowTo] Resolve an unbootable Manjaro (black screen, login failed, cant boot, etc)
Configure Graphics Cards - Manjaro

i dont have any problem on booting all my problem is GPU, but i think you are right, i remember i did try all sorts of things and i might have forced the installation at some point.