After today's large update, PC won't boot

It tells me that I am in emergency maintenance mode. It tells me what to do after logging in… But you
I can’t log in. Ctrl-D does nothing. “Failed to mount /boot/efi.” It reads as one of the log items, which seems really serious.

Er… Am I screwed?

Hopefully someone smarter than me will chime in but no your not screwed, you can fix most things with chroot and a live usb. What kernel version were you on ?

1 Like

Yeah, that’s why I don’t respond to many of these.

In the end, I found I could hold F8 on boot, and change to a different kernel to get back into the system.


I think I see what happened. I do not have the Linux 5.11 kernel installed, but for some reason after the update it tried to boot to 5.11. Weird.

Its always a good idea to keep an lts kernel installed. As kernels become EOL they get dropped from the repos and if you haven’t updated your kernel your left with no kernel. Pretty sure 5.1 is EOL now which is probably what happened

see this topic

check whats kernels ars installed , and what you have to remove
( number kernels installed should be the same as /preset/* )

do not keep EOL kernel ( version 5.11 5.12 are EOL , and 5.13 will be sooner EOL )
keep always version 5.4 or 5.10 LTS in this case

Y’see, that’s the point. I removed the 5.11 kernel BECAUSE it isn’t supported. But, there’s a problem somewhere with Manjaro, in that it doesn’t quite remove all of the kernel you told it to remove. Consequently, it tried to boot to a 5.11 kernel that isn’t installed.

In the end, I had to find the leftover 5.11 kernel detritus that Manjaro did not remove and remove it manually to move past this problem.

No - the package manager - pacman - is perfectly capable of removing a kernel.

It will even allow you to break the system by removing the running kernel - which mhwd-kernel will refuse.

So to remove a kernel - you would first install a new kernel - then reboot the system and use the package manager to remove the previous kernel.

This usually does not happen on pure Arch because Arch only have current stable and lts while manjaro has linux54, linux510 and more.

1 Like

Just realized I respnsed a topic was 1 month old.

Closed as no longer relevant