After system updated, application launcher not working

Two days ago, I updated my system using sudo pacman -Syu which downloaded about 3GB of software. After the update, I restarted my system and the application launcher has not worked since then.

I have to open the terminal and launch an app. However, my tools such as Emacs are not working correctly, and opening files from the File browser is not working. Even the login screen wallpaper changed. I hadn’t made any changes and restarted the system after the update. Please help.

Hi and welcome to Manjaro.

If this is related to the recent (but not that recent - you are a little late) upgrade to Plasma 6 then its likely the same as the other related posts.

That is I encourage you to follow the steps to clear old plasma cache and config from HOME.

Please see the update announcement or other threads.

These steps are a minimum:

Hello. Thank you for the comment. I followed the steps to clear the old plasma cache and config from home. That did fix the issue with the launcher. However other applications such as Emacs, NeoVim, etc are still not working properly. Any suggestions?

Try launching them thorough the terminal emulator and see if any, and what errors pop up. Feel free to provide the output here, if you need help to analyse it. But please don’t do it in this thread, as it has already been marked as solved. Instead, please rather start a new thread.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.