After switching to linux 6.1 the system works very badly how to switch back

OS:Manjaro btrfs
I need to change kernel to 515

It is very likely that you still have the previous one (515) installed
and can simply choose to boot it.
Press ESC after the firmware init and you get to see the Grub menu.

Did you remove 5.15 or do you still have it installed? If the latter, just reboot and choose “Advanced Options for Manjaro Linux” in the GRUB menu. This will then pop up a second menu where you can boot into 5.15.

If you no longer have 5.15, you must reinstall it first. :arrow_down:

sudo mhwd-kernel -i linux515
sudo update-grub

That second step should not be necessary, but it doesn’t hurt to explicitly update the GRUB configuration. You will then need to select 5.15 from the menu as explained here-above and boot into that one before you can remove 6.1.

If you do not see a GRUB menu at boot, open up /etc/default/grub in an editor, change the line… :arrow_down:


… into… :arrow_down:


Save the file and then run… :arrow_down:

sudo update-grub

Ok i will try, How do I know when the firmware is loaded?

Very shortly after power on.
There is usually a manufacturers logo and in the old days there also was a beep sound.
Just turn the machine on and keep pressing ESC
(repeatedly in fast succession - don’t just stay on it)

or do what @Aragorn just described

1 Like

I go to the boot launcher if i do that

whatever that means - I have no better advice
it always works for me :man_shrugging:

Thanks it works how i can paste 515 as default

Please read his post!

You don’t put 515 anywhere.
You change that line as described, save the file, then run the command update-grub
… both as root (use the sudo command - and be very, very careful what you write!)

On next reboot, you get to see the menu that you could not get by pressing ESC
Your choice will be remembered on subsequent boots.

If you have the following line… :arrow_down:


… in /etc/default/grub, then GRUB will remember your last selection and will boot into it automatically if you do not select anything manually. However, you may also want to remove the 6.1 kernel if it doesn’t work for you, in which case 5.15 will be the only kernel left on your system. :arrow_down:

sudo mhwd-kernel -r linux61 && sudo update-grub

its not working and writes some sing like sparse file is not allowed

That could happen if you’re using btrfs or lvm IIRC.
You’ve multiple options:

1 Like

Thanks very much! How to close this topic?

If you mark a post as solution the topic will automatically close a few days after the last activity.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )