After stable update system (2020-12-30) desktop does not adjust display resolution

After the update, I had the error failed to start Light Display Manager. Booted into tty and fixed it by reinstalling lightdm and by doing a general pacman -S -Syyuu. After that, the last step was to reinstall fbdev. After this, I could boot into my guy desktop environment.

Also, although the GPU is physically connected to the hardware, I never used it due to problems installing drivers. My main priority is to get a good working desktop, the GPU is not important.

The main problem is that now I can boot in the desktop environment, but the resolution cannot be adjusted. Before I had 5-10 options, now I can only choose one.

I tried installing the latest nvidia driver or removing it, but that does not change anything for the resolution. Everything else is working fine.

How do I get the resolution’s options again? Is there any config I can adjust?

Some info

> inxi -G
  Device-1: NVIDIA TU116 [GeForce GTX 1660 Ti] driver: N/A 
  Display: x11 server: X.Org 1.20.10 driver: nouveau 
  unloaded: fbdev,modesetting resolution: 1024x768~76Hz 
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.3.1