After showed "started simple desktop display manager" in installing, only a blink at bottom left corner of the screen

Downloaded manjaro-kde-21.1.6-211017-linux513 from Manjaro and created bootable USB flash drive by Rufus yesterday, Booted my HP EliteBook 8560p with AMD HD 6400/7400M from the USB, after showed “started simple desktop display manager”, there was a blink at bottom left corner of the screen, the installing progress not longer rolled down. I chosen both “Boot with open source drivers” and “Boot with proprietary drivers”, got same result.
I am a new comer for Linux, I guess my AMD has driver issue. Please help me. Where can I find old Manjaro version for the VGA if current version can’t support the VGA?

A) You were not actually installing Manjaro. You were booting the installation medium.

B) Installing an old version of Manjaro is not advised. You would be running outdated software with known vulnerabilities. Updating that old version with pacman would put you on the new version.

You are probably better off using one of images with an LTS kernel. For starters, the 5.13 kernel is EOL (“end of life”) and no longer supported, and the LTS kernels may have graphics drivers more suitable to your hardware.

By the way, AMD graphics do not require a proprietary driver. Their drivers are included in the kernel.

I agree with you that I was booting the installation medium. I can’t finish it. So, the old version can’t be updated by Pacman.
Thanks anyway.

There are only 3 version I can download on Manjaro .org, including manjaro-kde-21.1.6-211017-linux513, where can I download a LTS ?

Try here ─ these use the 5.10 LTS kernel. :arrow_down:

However, if the installation succeeds, then you’ll have to update your system right away, and make sure you read all the Stable announcement threads since this release was created in order to learn about all the caveats associated with the updates. :arrow_down:

Sorry, after downloaded it, I tried both options, the same issue happened, and if anything, the bottom left corner of the screen didn’t blink.

no anyway to fix it?