After Screen Lock, inputting password gets me to a black screen with functional cursor

I’ll drop this here, as I’m not certain it’s been absolutely clarified.

The .pacnew files should be merged with the content of the existing files, and should not replace the content.

Yes, this should seem obvious, I suppose, however, some don’t seem to understand the significance. A .pacnew file often contains updated and/or recommended information, which may sometimes conflict with desired settings.

This will often require that you so some research to find out exactly how each item of the proposed merge might affect your particular environment.

Just my 2 cents. Spend it wisely. Cheers.


Hrm… sometimes Meld seems to think that the .pacnew content should be added, and sometimes it seems to think that it should replace similar (but slightly different and presumably outdated) content in the .conf file. There have been a few instances where I did just that.

I hope I didn’t screw anything up. Most of the changes just seemed to be update to the comments, a few additional options and the like. But there was a GRUB file in there and I know that’s one of the worst places to break things.

There was a place I almost left the lines in (the one with [community]) but I was instructed earlier to specifically remove that one.

There was another that wanted to change the default file system from ext4 to btrfs? I didn’t dare change that one, but maybe I should?

I guess we’ll see… if everything breaks, then I’ll know I have made a terrible mistake somewhere.

Sometimes I think I’m in way over my head. Linux just doesn’t seem to be made for normal people, but at the same time it’s the last usable OS so it’s not like I have any choice (aside from giving computers up entirely, which in this day and age would be very difficult). I really wish the updater was just a bit smarter here, and replace the things it knows it has to replace while leaving people’s settings intact.

UPDATE: so the computer reboots just fine so I didn’t break GRUB. And while I hate to name myself… unfortunately, the “black screen with cursor” issue remains.

A responsible rule-of-thumb is simply this:

If you don’t understand how replacing any part of a file might affect your system, then skip that file until you’ve done some more homework.

Community was a no-brainer, as is said. The repo no longer exists, remove it.

Other pacnews, however, might have serious ramifications if you mess it up; usually recoverable; but, it does highlight the importance of caution.

BTRFS is apparently an excellent filesystem, with many advantages; however, not too many use it (I don’t). EXT4 is more than sufficient for most use cases, and it’s easier to manage.

Arch-based distributions such as Manjaro (being a rolling release) require more attention, generally; frequent updates and changes are just part of the deal.

We are all normal people (most of us), and we all came from something else before Linux. If you’re prepared to learn, you’ll reap the benefits.

So-called point release distributions, such as Debian (rock solid OS), have a different release cycle. Each major release is 2 years apart, with a few minor updates in between. You still need to understand and maintain your OS, but not as often.

Well, if you created a separate /home partition during install (using the manual partitioning method), that makes life easier, as you could do a full reinstall while leaving your home partition in tact.

Linux; it’s a journey. Cheers.

Meld doesnt know anything about pacnews or what ‘should’ be anywhere.
Its simply a comparison tool.
Which has been opened by pacdiff to help you manage the comparisons of pacnews and similar.
Any highlights, etc, that it shows are simply the mechanisms of showing the differences of the files.
Its up to you to compare, make changes, save, etc. Be aware of the filenames.

Now that you’ve done that please get rid of the old db;

sudo pacman -Sc

(removing the uninstalled cache is optional, but respond Y to removing unused repos)

Then sync+update again

sudo pacman -Syu

Assuming everything is updated and as it should be … now lets check on lightlocker;

Is the autostart file there?

ls -a /etc/xdg/autostart/

Or maybe in home?

ls -a ~/.config/autostart

And maybe check if its running

ps -ef | grep light-locker

If those seem to show it running then it should work;

light-locker-command -l

But we are here because it doesnt so … please report whatever oddities or errors.

D’oh, and we might still find general system information useful:

inxi -Fazy

warning: sndio: local (20180120-1) is newer than extra (1.9.0-1)
there is nothing to do

The etc/xdg/autostart line revealed a “light-locker.desktop” file.

Checking if it’s running, uh…

USERNAME 954 804 0 00:24 ? 00:00:00 light-locker
USERNAME 6274 6147 0 01:02 pts/0 00:00:00 grep --colour=auto light-locker

With “light-locker” being in RED. I’m guessing that’s not a good thing.

Running that last command yields:

** Message: 01:04:58.539: Received error message from the locker: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ScreenSaver was not provided by any .service files

I don’t know if that’s informative regarding the source of the issue, but it might be?

Edit: ah, system info. Yes.

  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=44c2f76f-7ed8-4eec-b84a-a712d686b73d rw quiet
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 2 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: H370 GAMING PLUS (MS-7B22) v: 2.0
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 1.10
    date: 02/24/2018
  Info: model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF4
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
    bogomips: 33613
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled, RSB
    filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI
    driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2023-11; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1c03 class-ID: 0300
  Display: x11 server: v: compositor: xfwm v: 4.18.0 driver:
    X: loaded: nvidia gpu: nvidia display-ID: :1.0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-size: <missing: xdpyinfo>
  Monitor-1: Unknown-1 mapped: DVI-D-0 res: 1920x1200 hz: 60 dpi: 89
    size: 550x343mm (21.65x13.5") modes: 1920x1200
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.274 layers: 5 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1060 6GB driver: nvidia v: 545.29.06 device-ID: 10de:1c03
    surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.0 status: off tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel Ethernet I219-V vendor: Micro-Star MSI driver: e1000e
    v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 11.38 TiB used: 5.05 TiB (44.4%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 PRO 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 1B6Q scheme: MBR
Bunch of HDD info
  ID-1: / raw-size: 459.76 GiB size: 451.47 GiB (98.20%)
    used: 371.76 GiB (82.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 17.17 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 32.0 C pch: 29.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 254 Uptime: 43m wakeups: 0 Memory: total: 16 GiB
  available: 15.57 GiB used: 3.15 GiB (20.2%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1556 libs: 533 tools: pamac,yay Shell: Bash
  v: 5.2.21 running-in: xfce4-terminal inxi: 3.3.31

The computer is a bit over five years old, but it has decent enough components which are still plenty for my needs.

Might be indeed.
The problem here is that file is not provided by any package.
The closest but still not exact is

extra/kscreenlocker 5.27.10-1 (plasma)

(which is also for kde)

So now the question becomes why is light-locker looking for that file ?

Can we check some things;

All installed foreign packages

pacman -Qmq

List all installed packages having to do with light, lock, or screensave;

pacman -Qsq 'light|lock|screensav'

Foreign packages:


All installed packages having to do with light, lock, or screensave:



Tip: If you place those loooong boxes between 3 backticks ``` (top and bottom), that will create a scrollable preformatted text box, and keep it tidy.

I see… I supposed that is technically code. I’ll try that now.

Edit: interesting. On GitHub they called it “code”, here they call it “Preformatted text”. Either way, it really is much tidier.

1 Like

Well, it’s technically preformatted text – all monospaced – like the html <pre>, for example. …aaaand, back to the Penguin!

It occurs to me that I’m not 100% certain I didn’t test the Screen Lock function again after I rebooted last time. If I did, I got back in using Ctrl+Alt+F2 and this breaks the Screen Lock function (until I reboot again), which may have tainted the results of those two earlier light-locker tests.

I’ll reboot quickly and redo those two tests just to make sure I get the same result.

Edit: the second result DID change. “light-locker-command -l” successfully triggered the Lock Screen function. Moreover, when I logged back in, I did not get a black screen.

Will retest this immediately, but if that’s the case, it would be a workaround; I could use the Lock Screen function via the terminal.

Edit 2: Confirmed! The command locked the screen, and I didn’t get a black screen when I came back.

So what’s different between that terminal command and the “Lock Screen” button on the UI? Why does one work and the other not? Come to think of it I’ll retest the button again just to be sure we didn’t somehow fix it too.

Edit 3: I used the Screen Lock button, no black screen!

How does that even make sense? I tried it after all those merges and it was still broken. And we didn’t actually change anything since then, I just gathered information and pasted it here. The only thing I did was call the screen lock function from the terminal one time.

Did it stick? I’ll reboot again, try the button before I do it via the terminal, and see if I get a different result.


Edit 4: it did not stick. I rebooted, and the button still gave me a black screen. I rebooted again and used the command in the terminal, and got a black screen again.

Why did it work twice in a row two sessions ago?

With a quick look over there appears to be many unsupported packages. Some that do not exist in the repos or the AUR, some that are questionable …

For sure you will want to remove the ones listed below, after making sure to have the modern counterparts (and light-locker for good measure):

sudo pacman -Syu breath-wallpapers polkit linux-firmware linux-firmware-whence light-locker
sudo pacman -Rns breath-wallpaper gksu-polkit gtk-xfce-engine manjaro-firmware mhwd-catalyst mhwd-nvidia-240xx

I probably suggest lots of other removals as well … including gconf, lib32-gconf, openssl-1.0, mozilla-common, most or all of the old js* packages, and more depending on what you actually need. vertex-maia-themes does not exist anywhere either. Your ipw* packages also dont exist, but there is ipw2x00-firmware in the AUR … etc etc.

I still dont know if any/all of that will have the desired fixes.
But I do know your light-locker appears to be looking for a file that does not exist … while you have old packages, some of which have not existed for a while.

Its no lost cause … but its worth asking at some point if maybe it would be less pain or quicker to do a backup and clean install? It wouldnt be my first choice :smiling_imp:, but I have a hunch that it would work then (of course a Live USB can always be test-driven).
Only you can value your own time and all.



We can both be unsure of the mystery of the exact sequence of events, but if it works thats great.

What I said above about the old packages is still general advice though. :slight_smile:

Some more of that …

Your BIOS appears to be out of date.
If my search-foo is correct:

This isnt quite dangerous yet, but you will want to make sure not to tip in towards 10% free.

Can having old packages actually be harmful? I thought they’d just stay sort of unused…

I’ll check I’m up to date on those just in case, and I suppose I can remove some of these.

Are you sure about Vertex-Maia? It’s always been among the default available themes for me. I just reinstalled Manjaro on my laptop and it was there. The theme I use is actually one of the Vertex-Maia ones.

Reinstalling everything from scratch… I know it’s the “clean” solution, but oh boy is it a nightmare. Days and days of reinstalling things, of things not working like you’re used to and trying to figure out how to set things back to normal. I always dread doing that.

In the meantime I really don’t know what to do about this ridiculous black screen issue. Maybe they’ll fix it in a later update? Usually they don’t, but sometimes they do…

It depends. If it was a selfcontained application it might roughly work that way.
(themes are a pretty good example … though having an old one enabled could break stuff)

But some might provide services or configurations whose continued existence may contradict new norms.

As sorta mentioned in the other thread … we arent really sure its a bug.
Given the myriad of ‘issues’ its quite difficult to say without checking something like a live ISO.

If it isnt a bug … then no fix will come. Your misconfigured system … will continue to be misconfigured.

I can offer another big hammer approach …

Using mapare we can reinstall all the packages that would come with a current ISO.

And we can run it sorta ‘remotely’ (wihtout having to download and mark executable, etc)

bash <(curl -s -IA

Type xfce at the prompt.

When that is done check your pacnews, but then you can consider every foreign package as disposable as you see fit (read: remove everything unless you really want it).

And then we can go over some other things;

sudo pacman -Syu install-grub
sudo install-grub
sudo mkinitcpio -P
sudo update-grub

That should be a pretty good jumping point.

Another hint: if your regular user is not fixed try with a new user, if the new user works then it is a home configuration problem.

1 Like

Well, these updates change literally millions of things, so there’s no realistic way for me to figure out which one of these configuration changes my particular system might conflict with.

I read somewhere that there might be alternative ways to control these functions. Another manager might still be able to Lock Screen without triggering this black screen.

Ah well. That’s for another day.

Thanks so much for your help. I learned a few things and, after I remove a few of these, hopefully I might avoid problems in the future. I’ll have to remember to check for new .pacnew files after every update, too. Apparently they don’t happen super often (a couple a year?) but if they can break things, it’s important to know they might be a possible cause.

Thanks again.

Edit: as added information, I have tried switching to another user and using Lock Screen. I got the “black screen with functional cursor” issue there too. So it’s not a “home” configuration problem.

So looking back at the profile

and this other thread:

It would seem that the current way is not light-locker.
Its since become xfce4-screensaver with light-locker commented out.
(Though in that other thread they opted to go with light-locker)

It also reminded me you probably would be launched the lock instead with


Sorry I havent been using XFCE in some time so I cant check these things myself.

1 Like

Huh. That’s odd. I do not even have xfce4-screensaver installed.

But I just tried xflock4 and it did not cause the black screen issue! Now, we know that’s not a guarantee (yesterday there were two instances where locking the screen did not result in that issue somehow), but as it worked on the first try, it’s promising.

I’ll try it again later, before and after I reboot, and if it doesn’t cause the issue then… that’s a suitable workaround.

Maybe there’s even a way to tie this function to my Lock Screen button.

Thats encouraging.

Extra info to go over here:

It appears you shouldnt really need to do anything extra as long as the lock being activated is xflock4, which according to the article should be true for the ‘Action Buttons’ in the panel.

If you have a key combination configured that may need to be adjusted/reapplied.

xflock4 seems to work every time. Good enough for me! I’ll see if I can figure out how to tie the button to that command, but until then, I don’t mind having to open a terminal and input that one word when I need to lock the screen.

I’ll mark it as the solution so at the very least, if someone encounters the same problem, they’ll also have a nice workaround.


Edit: mark, not make

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.