After reinstalling Manjaro KDE, why is how can I "link" my OS partition with the regular files partition, so that `root` points to it?

Today I accidentally rebooted my computer while performing a massive system upgrade, which nuked my Manjaro install. After live booting from an USB, mounting my /dev/sda3 partition (which stores the OS) and realizing through chmod that the mess was to big, I decided to simply reinstall Manjaro. It’s always fun, isn’t it?

This is my HDD partition table.

>>> sudo fdisk -l

Device         Start        End    Sectors   Size Type
/dev/sda1       2048    1026047    1024000   500M EFI System
/dev/sda2    1026048   17410047   16384000   7,8G Linux swap
/dev/sda3   17410048  222210047  204800000  97,7G Linux filesystem
/dev/sda4  222210048 1953523711 1731313664 825,6G Linux filesystem

As I understood, the OS would live inside /dev/sda3 while the root directory (together with folders such as Documents and the like) would be inside the /dev/sda4 drive.

This by the way actually worked with my previous install: the OS was at sda3 while my “personal” files lived in /sda4. Now, however, /sda4 appears as an additional device and, if I run cd or ls, for example, I navigate within /sda3.

Is there a way can somehow “link” the OS partition with /sda4 and go back to normal?


you mean you want to have the old home partition in the new install?

I think you have to modify your /etc/fstab to mount your /dev/sda4 to /home.

1 Like

Correct, but I don’t want to merge the partitions or expand /sda3 to the left.

I see. Let me try out that option. Thanks!

Okay, checking /etc/fstab shows:

>>>> nano fsatb
  GNU nano 6.3                                        fstab                                                   
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=C01A-E1F4                            /boot/efi      vfat    umask=0077 0 2
UUID=0e5444a1-6464-4a06-9991-9bf167730f47 /              ext4    defaults,noatime 0 1

It also shows that the file is unwritable. How would I modify it?

1 Like

Thanks. I was just reading it!

Okay, so after reading the article that you provided (thanks!) as well as this very similar question, I have to:

  • Mount /sda4 (my old partition) inside my home directory, as I’m the only user in my laptop.
  • Then, edit the entry in /etc/fstab where type is / (which is root), so that it points to the recently created mount point in home?

How do I avoid a duplicate home directory? And wouldn’t the second step remove the mount I just created?

The root mount cannot be moved.
You simply need to add the configuration for mounting /sda4 – actually, it is recommended to use its UUID instead – to /home.

Check the configuration works with :point_down: and if it’s right, you’re done.

mount -a