After Recent Update > Why do I now get a Broadcast message on shutdown?

I recently let a system upgrade download and install in my Manjaro and now when I shutdown I get a message just before the laptop turns off:

"Broadcast message from [logged in user @ "Computer name"]. The system is going down for a poweroff now!"

I didn’t ever use to get that message before and I have started getting a beep sound as well right before shutdown.

I already tried this:
echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf

But I still get the message and instead of getting the beep that sounds like it’s coming from the BIOS I now get another sound that sounds more like it is coming from the sound card.

This issue is also mentioned here possibly related to a recent update to systemd? The echo "blacklist pcspkr" thing did not work for me.

Can I get rid of both the message and the beep?

Kind regards,


1 Like

Indeed, seems like a journald issue.

A PR that was merged 17 days ago might be of interest.

I find it hard to follow that thread?

One poster says: "It shows messages about shutdown (or its cancellation). It won't show messages about suspend, but I think that's acceptable." And then other stuff happens after that but not well explained.

Do you think that fix will stop the broadcast message and beep on shutdown? Also, I don’t know how to get any more recent updates, my Manjaro is telling me my system is up to date but I am still getting the broadcast message.

Go back to that file and remove the quotes from “blacklist pcspkr”

blacklist pcspkr

This command:

will result in exactly this

being in that file …
The quotes will not show up.

1 Like

I just copied that command from a website. My nobeep.conf doesn’t have the quotes in there.
I still have the beep and message on shutdown.
Looks like we are stuck with this until another update comes through.
Thank you

@Nachlese @flexmcmurphy

That’s what worked for me. Mine had the quotes when I did it, and the fix was posted on the stable-updates post.

`blacklist pcspkr` does work! but the instructions in the testing thread are incorrect.
If you run `echo “blacklist pcspkr” | sudo tee /etc/modprobe.d/nobeep.conf` you’ll then need to edit the file & remove the `"` speechmarks. Then the beep is disabled.

Oh well. I hope you find the right fix for yours.

Maybe you have an older version of systemd and the kernel.

On my installation I have:

systemctl --version
systemd 251 (251.2-3-manjaro)


uname -a             
Linux flex-manjaro 5.15.48-1-MANJARO #1 SMP PREEMPT Thu Jun 16 12:33:56 UTC 2022 x86_64 GNU/Linux

Both the same as yours. :thinking:

Could it be a difference in hardware? Mine is on a Dell Optiplex 990.


Apparently systemd now wants to broadcast that it’s going to shutdown.
The beeping has nothing to do with the message.

The beeping must have something to do with the broadcast message because they both suddenly appeared at the same time when previously I didn’t have either.

I am using KDE Plasma. So far I tried all the suggestions in the Arch Wiki for PC Speaker.

Added blacklist pcspkr to /etc/modprobe.d/nobeep.conf

Added setterm -blength 0 to /etc/profile

Added set bell-style none to /etc/inputrc

Added this to ~/.bashrc

alias less='less -Q'
alias man='man -P "less -Q"'

I finally got a temporary workaround for this issue. Full explanation in this thread.

In my case I needed to do TWO things:

Step 1

# sudo nano /etc/modprobe.d/50-blacklist.conf
blacklist pcspkr ← Then add this line and save that file.

Or simply:

echo "blacklist pcspkr" | sudo tee /etc/modprobe.d/nobeep.conf

This seems to stop the very harsh loud sound that was maybe coming from the motherboard? But that just gets replaced with a different sound that is quieter and maybe coming from some program running in Manjaro OS?

Step 2
System Settings → Notifications → Applications: Configure → Local System Message Service → Configure Events and uncheck Play a sound"

Then you need to reboot TWICE because those settings don’t take full effect until you reboot once. So you need to reboot AGAIN to test if it worked.

Now I still get The system is going down for a poweroff now!" “Wall” message at shutdown or reboot but I can live with that.

I already had xset -b in ~/.xprofile for the last year or so and was successfully using that to stop the beep sound. But whatever change was made to systemd that fix was not working for me anymore.

Another Note:
I had the same problem on a Thinkpad laptop. But on that laptop I only needed the “System Settings” (Step 2) solution to stop the beeping. So what you have to do may vary depending on your hardware.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.