After prematurely shutting down upgrade and trying to fix missing kernel, cant load manjaro from grub (nvme)

Hi! I am quite a novice with boot up and grub stuff, would appreciate any help / pointers.

Today accidently did REISUB in the middle of a system update. In turn got a classic error about kernel not being installed. Since this is a common problem, I tried following this: [HowTo] Recovering from an interrupted update/upgrade

However, that did not help in the slightest - on contrary, now I can’t even load manjaro menu (the place where I could choose the kernel). When I select “Manjaro” from the boot menu, it simply redirects me to lenovo ThinkPad boot settings menu. I suspect that maybe my manjaro installation wasn’t done in the default way, thats why following ext4 path didn’t help…

What I tried:

manjaro-chroot -a

I got:

[manjaro ~]# manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]# 

I suspect that dev/sda1 comes from my live usb stick, since lsblk returns this:

loop0         7:0    0   32.7M  1 loop /run/miso/sfs/livefs
loop1         7:1    0  868.9M  1 loop /run/miso/sfs/mhwdfs
loop2         7:2    0    1.4G  1 loop /run/miso/sfs/desktopfs
loop3         7:3    0 1003.1M  1 loop /run/miso/sfs/rootfs
sda           8:0    1    7.2G  0 disk /run/miso/bootmnt
├─sda1        8:1    1    3.3G  0 part 
└─sda2        8:2    1      4M  0 part 
nvme0n1     259:0    0  476.9G  0 disk 
├─nvme0n1p1 259:1    0    260M  0 part /mnt/boot/efi
├─nvme0n1p2 259:2    0     16M  0 part 
├─nvme0n1p4 259:3    0   1000M  0 part 
└─nvme0n1p5 259:4    0  465.2G  0 part /mnt

However, after running

[ -f /var/lib/pacman/db.lck ] && rm -f /var/lib/pacman/db.lck
pacman-mirrors -f && pacman -Syyu

And rebooting I get same issue where I am “redirected” back to boot menu of computer itself.

I also tried to use “Detect EFI bootloaders” option from usb stick boot menu and I see one option that looks like my kernel: (hd0,gpt1)/efi/Manjaro/grubx64.efi, but trying to select it does the same redirect :confused:

from the update-grub I also get this output, maybe the unknown device type line is a little suspicious?

[manjaro /]# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
ERROR: mkdir /var/lock/dmraid
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.

You should probably rather issue each command separately, so that you can better observe the output and possible error messages of each one.

The first line is to check for and remove the lock file if it is present.
pacman-mirrors -f is refreshing the mirror list
pacman -Syyu is the actual update command and it’s output might hold clues
update-grub then should recreate the initrd
exit will end the chroot session and put you back into the live session

If there where no issues along the way, it should work.
It appears that it still does not work - in that case I have no clue at all what the issue might be.

One thing I wondered:
what are the two partitions
nvme0n1p2 and nvme0n1p4?
They are rather small …
lsblk -f
will tell you more in case you don’t know what they are for

1 Like

Thanks for the answer! Yup, I ran them separately, but didn’t see any meaningful output about errors or anything else.

Managed to boot my manjaro right now, but not sure why this approach worked as I tried it randomly:

  1. Created a new grub menu entry
  2. Installed a new kernel (linux68) from within the manjaro-chroot -a) with mhwd-kernel -i linux68

Just a little scared that probably half of my system configuration is somewhat broken. Is there a way to clean up a little bit?

Also, in regards to lsblk -f:

├─nvme0n1p1 vfat     FAT32 SYSTEM    1AC1-EA44                             226.9M    11% /boot/efi
├─nvme0n1p4 ntfs           WinRE_DRV 187CC47F7CC458E0                                    
└─nvme0n1p5 ext4     1.0             925ddc63-3633-4fb0-a2b5-cc0204a54ceb  161.8G    60% /

The nvme0n1p2 and nvme0n1p4 are somewhat connected to windows partition that I had ages ago. I used to have dual boot on this laptop, but at some point removed windows and extended my manjaro partition. Probably these are left overs.

Why would you be scared? Any signs of broken things?

With some updates there may be changes to some configuration files.
Those are not applied automatically - you have to tend to them yourself and individually(!).
These files are in /etc and have the ending .pacnew

Tend to them - but be careful.
Especially when it comes to /etc/shells or /etc/passwd …
Know what you are doing or ask.

Other than that:
people have written various scripts to “clean” the system.
Not really necessary in my opinion, but to each his own. :wink:
You’ll find them here with some forum search.

1 Like

Hm, after some tinkering around with settings, it seems like everything is working. Had to remove the old kernels as I couldn’t boot up the system with them (would redirect me to the computer setup).

Thank you for the help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.