After pacman -Syu RStudio stopped opening

Hi,

I updated my system using pacman -Syu on 2020-11-06 and now rstudio-desktop-bin (most recent version from AUR, , v1.3.1093-1) does not open consistently. Sometimes it opens a window then closes it immediately, sometimes it’s a black window, and sometimes it opens a window and appears normal but crashes in short order. Anyone else having this problem?

inxi -Fazy:

System:
  Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=b6fb2e8b-3700-4370-94dc-da42962edaa6 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: ASUSTeK product: N/A v: N/A serial: <filter> 
  Mobo: ASUSTeK model: WS C246 PRO v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 0802 date: 11/30/2018 
CPU:
  Info: 8-Core model: Intel Core i9-9900K bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: C (12) microcode: D6 
  L2 cache: 16.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 115232 
  Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
  4: 800 5: 801 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 
  14: 800 15: 801 16: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: PNY driver: nouveau 
  v: kernel bus ID: 01:00.0 chip ID: 10de:1f02 
  Display: x11 server: X.Org 1.20.9 driver: modesetting,nouveau 
  alternate: fbdev,nv,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 7680x2160 s-dpi: 96 s-size: 2032x571mm (80.0x22.5") 
  s-diag: 2111mm (83.1") 
  Monitor-1: DP-1 res: 3840x2160 hz: 60 dpi: 163 size: 600x340mm (23.6x13.4") 
  diag: 690mm (27.2") 
  Monitor-2: HDMI-1 res: 3840x2160 hz: 60 dpi: 163 
  size: 600x340mm (23.6x13.4") diag: 690mm (27.2") 
  OpenGL: renderer: NV166 v: 4.3 Mesa 20.2.1 direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Device-2: NVIDIA TU106 High Definition Audio vendor: PNY 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f9 
  Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-LM vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: efa0 bus ID: 00:1f.6 chip ID: 8086:15bb 
  IF: eno1 state: down mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: wl v: kernel modules: bcma port: 4000 
  bus ID: 04:00.0 chip ID: 14e4:43b1 
  IF: wlp4s0 state: up mac: <filter> 
  Device-3: Intel I210 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k 
  port: 3000 bus ID: 06:00.0 chip ID: 8086:1533 
  IF: enp6s0 state: down mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
Drives:
  Local Storage: total: 14.60 TiB used: 679.02 GiB (4.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW020T8 size: 1.86 TiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 002C scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST8000DM004-2CX188 size: 7.28 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5425 rpm serial: <filter> rev: 0001 scheme: MBR 
  ID-3: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A3 
  size: 5.46 TiB block size: physical: 4096 B logical: 512 B serial: <filter> 
  rev: 1021 scheme: GPT 
Partition:
  ID-1: / raw size: 1.86 TiB size: 1.83 TiB (98.38%) used: 679.02 GiB (36.2%) 
  fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 31.25 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swap/swapfile 
Sensors:
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nouveau temp: 46.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 657 
Info:
  Processes: 309 Uptime: 8m Memory: 62.68 GiB used: 2.47 GiB (3.9%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
  pacman: 1255 lib: 371 flatpak: 0 Shell: Bash v: 5.0.18 
  running in: xfce4-terminal inxi: 3.1.08 

Thanks!

Matt

If you havent rebuilt your AUR package against current system libs then thats why.

1 Like

@cscs thanks but I installed the latest rstudio-desktop-bin from AUR after I did the system update

Hm. What happens if you launch it from terminal? Any clues?

Maybe something here! When I launch from terminal and it crashes, I see many lines of “nouveau: memory address” then this error. But sometimes it freezes everything and I have to force reboot.

nouveau: 	0x001f001e
nouveau: 	0x0020001f
nouveau: 	0x00210020
nouveau: 	0x00230022
nouveau: 	0x80000585
nouveau: 	0x200406c0
nouveau: 	0x00000000
nouveau: 	0x00014000
nouveau: 	0x000004f9
nouveau: 	0x1000f010
[3202:3203:20201109,161157.589632:ERROR file_io_posix.cc:148] open /home/mcsimenc/.r/crashpad_database/pending/0aa2ed44-3856-4a36-adc5-e852ff28e890.lock: File exists (17)
[3202:3202:20201109,161157.591859:ERROR process_memory_range.cc:86] read out of range
[3202:3202:20201109,161157.591865:ERROR elf_image_reader.cc:558] missing nul-terminator
[3202:3202:20201109,161157.591983:ERROR process_reader_linux.cc:445] no module mappings 0x7f737a0fd000
[3202:3202:20201109,161157.593840:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.593996:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.595087:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.595128:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.595943:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.595974:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596004:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596033:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596064:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596120:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596151:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596179:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3202:20201109,161157.596209:ERROR elf_dynamic_array_reader.h:61] tag not found
[3202:3203:20201109,161157.598011:ERROR directory_reader_posix.cc:42] opendir: No such file or directory (2)
Segmentation fault (core dumped)

That won’t help because you just reinstalled the same binary files that were built against older libraries. Build rstudio-desktop or rstudio-desktop-git and you should be good to go.

Awesome thanks @Yochanan.

I installed rstudio-desktop but RStudio doesn’t work: it loads but the main part of the window remains blank.

I also tried to build rstudio-desktop-git but got this error:

CMake Error at src/cpp/session/CMakeLists.txt:30 (message):
  pandoc 2.11.1.1 not found (re-run install-dependencies script to install)

However the most recent pandoc in the Arch repository is older than that, version 2.11.0.2-1

Not sure what to tell you then. It could be an upstream issue. Have you poked the internet? :wink:

We don’t even have that in the Manjaro unstable branch yet. Arch just updated to 2.11.0.2-1 today. They may be holding it back to avoid breakage with packages that depend on it.

I’ll do some more poking around

Ok, thanks for your help!

Might be a bit of a shot in the dark, but have you tried removing RStudio’s cache and config files (plus any other crud it leaves around the home directory)?

I’m currently using the latest rstudio-desktop-bin from the AUR without issue. Looking at your inxi output the main differences between our systems that ‘might’ make a difference are GFX card manufacturers (Intel + AMD vs Nvidia), desktop environment (Gnome vs XFCE), desktop session type (Wayland vs X11), kernel version (5.9 vs 5.8) and monitor resolution (2 x 1080p vs 2 x 4K). Not sure if that’s helpful or not, but might give some clues if removing the config/cache stuff doesn’t help.

Otherwise, have you checked the comments in the AUR?

Thanks Freakster!

Yeah, removing the config/cache directory didn’t affect the problem.

I tried installing kernel v5.9 using mhwd-kernel -i linux59 because pacman -S linux installs v5.8 even though v5.9.6 is the latest in the Arch repository. Changing my monitor resolution didn’t change RStudio’s behavior either. I’m under the impression that I can’t use Wayland with XFCE.

I tried to install Gnome using pacman -S gnome but I think it tells me I have gdm-dev installed and also that gdm-dev conflicts with libgdm-dev. But pacman -R gdm and pacman -R gdm-dev report target not found.

looking for conflicting packages...
warning: removing 'gdm' from target list because it conflicts with 'gdm-dev'
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: gdm-dev and libgdm-dev are in conflict

I didn’t see anything relevant in the AUR comments.

pacman -Qs gdm