After last update Skype stopped working. I am looking for a fix

Hi everyone!
Please help!
Skype opens, I get notified for incoming messages yet the UI is invisible!
Has anyone encountered something similar?
I have the latest version installed yet the problem exists for more than a week, after a major upgrade to manjaro.
Please, if there’s a fix do suggest it, I am lost without Skype! I constantly need to login to :frowning:
Thank you all!

Hi @vatosflokos,

I also have it installed, the skypeforlinux package:

$ pamac search skypeforlinux
skypeforlinux-preview-bin                                                                                                                                                                                                        AUR
Skype for Linux - Preview/Insider Version
skypeforlinux-stable-bin                                                                                                                                                                                                     [Installed]   AUR
Skype for Linux - Stable/Release Version

And I just tested it (I don’t really used, installed it for a job passed.) and it seems to work fine!

I see it’s in the AUR. So, my question then, have you rebuilt it after the update?

pamac build skypeforlinux-stable-bin

Hope this helps!

Thank you for your kindness replying back.
I did tried your suggestion but the results are the same. Skype loads, I get notifications, when I press “Super” key I see that it takes space amongst the other apps but the UI is invisible (as the photo shown below).
But thank you for trying to help me out.

Maybe a total uninstall and then a re-install would help? I do not know, I am just guessing.
Thank you :slight_smile:

UPDATE: Maybe if I try to run the app from the terminal we could see what’s wrong and the UI is not loading. I am running though “skypeforlinux-stable-bin” and nothing happens. Sorry, a noob here :slight_smile:

It is doubtful that a remove and re-install will work. I would check if there is a config folder in your home directory, back it up and see if the software creates a new one. Maybe corrupted config?

Try and run from terminal and note any errors that you may see and post them here.

Rebuild again as the package was updated today per AUR page:

Last Updated: 	2023-06-15 11:34 (UTC)
1 Like

Thank you my friend.
I did that but I run the command “skypeforlinux-stable-bin” which is installed in my system and I see no errors. Again. Skype loads but the UI is absent.
So confusing!
I really appreciate it for taking the time to advise me!

I don’t use this software. try typing skype at the terminal prompt.

Check my previous answer. When I run the app from the terminal, the app loads with no errors but again the UI is absent.

You might want to post a full inxi output here as maybe it is a video driver issue. Are you using wayland? Is the system fully updated? There really isn’t much information that you have supplied that can give a more savvy user a hint as to what the issue may be. The screenshot is pretty useless.

The actual command is skypeforlinux, but it runs in detached mode.

  1. Check this file for startup logs:
cat ~/.config/skypeforlinux/logs/skype-startup.log
  1. Backup the config folder and try to start Skype again:
mv ~/.config/skypeforlinux/ ~/.config/skypeforlinux-backup/

And one more:

I see only (9 days ago) and (today). There is no such build in AUR. Do you use some custom repository, that provide this build Check it with:

pacman -Qi skypeforlinux-stable-bin
1 Like

Hi and thank you :slight_smile:
This is the output of the first command
cat ~/.config/skypeforlinux/logs/skype-startup.log  ✔ Quitting secondary Skype instance! ioctl failed for wlan0, errno = 19 (No such device) ioctl failed for wlan0, errno = 19 (No such device)    ~ 

I also have the same version with you ( - sorry I mistyped it.

I can understand that novice users like me can be a real trouble some times(or almost always :slight_smile: ) that’s why I really appreciate the time you dedicate to my problem.
As your questions my system is fully updated and I am using wayland.
I am really sorry for all the trouble!

inxi                                                             ✔ 
CPU: 8-core AMD Ryzen 7 4700U with Radeon Graphics (-MCP-)
speed/min/max: 1400/1400/2000 MHz Kernel: 5.19.17-2-MANJARO x86_64 Up: 1h 5m
Mem: 4110.1/15214.5 MiB (27.0%) Storage: 953.87 GiB (32.2% used) Procs: 305
Shell: Zsh inxi: 3.3.27
    ~  echo $XDG_SESSION_TYPE                                           ✔ 

Try with x11. Wayland is still experimental.

1 Like

I also have the following error, as I said already to another user

cat ~/.config/skypeforlinux/logs/skype-startup.log  ✔ Quitting secondary Skype instance! ioctl failed for wlan0, errno = 19 (No such device) ioctl failed for wlan0, errno = 19 (No such device)    ~ 

Try this, because the log above shows, that skype is running for the second time:

killall skypeforlinux
cat ~/.config/skypeforlinux/logs/skype-startup.log

And also try to start it with clean config.

That’s fine.

I suspect it’s a local issue, as it seems to work fine for me. Maybe make a backup of the skypeforlinux folder found in ./config` and (move it somewhere else) rerun skype to see if the issue persists?

Sorry I see someone else already suggested this.

I deleted the config folder and IT WORKS!
Thank you!!

1 Like

Thank you very much sir. I just deleted the .config folder and it works!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.