After interrupted pacman update: can't boot in graphical environment

During a larger pacman update the notebook (Lenovo Thinkpad X1 Tablet Gen. 2) shut down as it was out of battery (power cable unfortunately not connected).
I don’t know at which point of the update the shut down happened, but now I can’t boot in normal (graphical) mode.

Steps to solve (unsucessfull):
I did many things I found from searching for similar problems, including chrooting from live linux and re-installing / updating various stuff i.e.:

  • pacman -Syyu
  • re-initiated initramfs mkinitcpio -P
  • grub-install (EFI-mode)
  • update-grub
  • re-installing video-linux driver unsing mhwd
  • installing a newer kernel (5.13) using pacman -S linux513

All steps work in themselves, but didn’t help to solve the boot problem

When I boot I get into grub and can start any of the installed kernels. Removing quiet and splash from the boot command shows the normal boot messages all [ OK ]

After the boot script ran I only see a black screen with an underscore. Switching to another TTY does not work. Only ctrl+alt+del works and starts a reboot. Now I found out, that I can successfully boot into runlevel 3 by setting it in the boot command. From there I can also switch between TTY’s and login as user.

When logged in I tried startx, which gives:

/etc/X11/xinit/xserverrc: line 2: /usr/bin/X: Success
xinit: giving up
xinit: unable to connect to x server: connection refused
xinit: server error

Same error I get with xinit gnome-session

Any ideas what could be wrong here?

Hi @nibor, and welcome!

I recommend chrooting into your system, from the live environment again, but this time don’t run pacman.

Instead, use pamac, Manjaro’s package manager.

pamac checkupdates && pamac update -a

Hope this helps!

1 Like

Lot’s of helpful info in the wiki:

1 Like

@Mirdarthos thanks I tried with pamac as well, but the only packages it lists with available updates are some that I have installed from AUR and which have no system-critical functions. No packages from the regular repositories have pending updates anymore.

@Wollie, thx as well, I had looked through the wiki pages already and also tried some of the suggested steps (i.e. refreshing keyrings). Since the first time I was in chroot, there were already no problems running updates through pacman. So everything is up to date now and further attempts just result in pacman saying there is nothing to do.

Did you recreate the initramfs with mkinicpio -P (in chroot, of course)

You could reinstall all packages that are currently installed but I don’t know if Manjaro supports that right away without any problem.

yes I ran mkinitcpio -P in chroot (I now added it to the list of things tried in OP, where I forgot it before)

I also tried it again, after changing the hook orders in /etc/mkinit.conf, as I’ve read here that in case of a luks encrypted partition (which I have) keyboard should be added before autodetect (see here: However this did not change anything, and also I think mounting of my partitions is not the problem here: prompting for the encryption password before entering grub works as normal, boot messages suggest normal recognition of my root partition, and I can successfully boot into runlevel 3.

My bet is it’s something wrong in video / graphics setup, that does not let X start. Do you have any ideas for further check, tests or logs I could provide to track down what’s going wrong here?

I have tried one more thing: reinstalling X and intel video drivers from chroot

pacman -Su xorg xorg-server xf86_video_intel

Still problem persists. I am out of ideas. In a thread to a similar problem @Inko ended up reinstalling the system. I guess that’s what I’m going to do…