After install windows is no longer available in bios(to boot) or in grub


I apologize I am quite new to linux and do not too familiar with the terminal.

I am running an up to date manjaro 23.0.4 kde version on stable kernel. I have two disks on my computer, a nvme and an SSD. My working windows 10 install was and still is on the nvme and my install of manjaro is on the SSD.

After the installation of manjaro I cannot boot into windows from the bios (it is not even listed anymore) and there is no windows entry in grub.
I have verified that the windows partition is in tact and the files are all still there.

After doing that I searched the forum for a bit and tried several things including using os prober and also the information from this guide: [root tip] [How To] Dual boot Manjaro and Windows - #11

Unfortunately I could not get windows back with those resources.

Could someone please assist me with this issue?

I browsed the forum

sudo update-grub

Beyond that you can list the things for us, ex:

sudo fdisk -l

Thank you for your quick reply.

update-grub has not changed anything.

Here are the results of the other two commands you gave me:


sda 8:0 0 223.6G 0 disk
├─sda1 8:1 0 300M 0 part /boot/efi
└─sda2 8:2 0 223.3G 0 part
└─luks-b59fb893-54f4-4752-a46b-ce169da1d012 254:0 0 223.3G 0 crypt /
zram0 253:0 0 10.9G 0 disk /run/zram0
zram1 253:1 0 7.8G 0 disk /run/zram1
nvme0n1 259:0 0 931.5G 0 disk
├─nvme0n1p1 259:1 0 16M 0 part
└─nvme0n1p2 259:2 0 931.5G 0 part


sudo fdisk -l

Disk /dev/sda: 223.57 GiB, 240057409536 bytes, 468862128 sectors
Disk model: INTEL SSDSC2BP24
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: D233485A-845A-4610-9566-256A8951BC93

Device Start End Sectors Size Type
/dev/sda1 4096 618495 614400 300M EFI System
/dev/sda2 618496 468857024 468238529 223.3G Linux filesystem

Disk /dev/nvme0n1: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: SHGP31-1000GM-2
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 65E92CEC-DEED-4432-B034-559227EE1727

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 34815 32768 16M Microsoft reserved
/dev/nvme0n1p2 34816 1953523711 1953488896 931.5G Microsoft basic data

Disk /dev/mapper/luks-b59fb893-54f4-4752-a46b-ce169da1d012: 223.27 GiB, 239736029696 bytes, 468234433 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/zram0: 10.87 GiB, 11670650880 bytes, 2849280 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/zram1: 7.76 GiB, 8336179200 bytes, 2035200 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


From those outputs and your previous statement I would suppose that

  • sda2 is manjaro root

  • sda1 is your ESP (efi system partition)

  • nvme0n1p2 is windoze

nvme0n1p1 is pretty small at 16M … was that the original windoze ESP ?

What you are looking for is the windoze boot loader. This should be visible to both BIOS and grub.
It was ostensibly initially on nvme0n1p1. Can you verify it is intact?
Manjaro would not automatically touch any of these partitions, nor of course your BIOS.
Though this would not preclude you from formatting or otherwise tampering with them.

Is it possible you changed certain BIOS settings in order to boot the manjaro ISO?

Things unrelated to the title query:
You seem to have multiple zram (swap) devices … is that on purpose?

These three points are correct.

Whatever is on the nvme is what windows originally created on the disk. I’m not sure what that 16 MB partition is.

I had attempted to create only one for the first time because I was running out of ram. Not sure how I ended up with 2 haha

How would I verify this? Is there a type of file I am checking for?

I do not think so. I only clicked the erase entire disk feature on installation and never touched the bios before or after.

I believe its something like bootmgfw.efi and/or winload.efi

Out of curiosity … what does sudo update-grub print?
When windoze boot loader is detected it should do something like:

Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi

Thank you again for helping I would have no idea what to do without help.

I will dig around the partitions to see if I can find anything like this.

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.5-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.5-x86_64.img
Found initrd fallback image: /boot/initramfs-6.5-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Root filesystem isn't btrfs
If you think an error has occurred, please file a bug report at ""
Found memtest86+ image: /boot/memtest86+/memtest.bin
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi

It seems update-grub does not find it, no.
You might want to make sure these other partitions are mounted before running it.

I mounted the windows partition and ran the command again with the same result.

There is no ESP on the disk with Windows leaving the thought that Windows is booted in BIOS mode and Manjaro in EFI mode.

This will never coexist - to dualboot different operating systems, all must use the same loader type.

How can I fix this then?

I didn’t say it was the problem - I said it is was a thought.

How can you know it is working when you cannot boot into it?

A win10 BIOS/GPT has at least 3 partitions - if it came with the system there wouild likely be 4 or more - taking into account possible vendor recovery images and shells.

But your install location on the nvme shows only two.

Which begs one to consider - why is that?

Is the Windows installation functional at all?

Was the Windows ESP on the SSD? So when you wiped the SSD to install Manjaro, you effectively dismantled Windows?

To return to your question: No. There is no definite answer to how you fix this.

The most obvious would be to drop Windows and use Manjaro.

If you must have Windows then - as you can access the Windows datapartition from Manjaro - back up your data and reinstall Windows.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.