After I change keyboard type, boot hangs before splash screen

On Kde settings, I change keyboard type from 85 to 105 keys and I activated the meta key in the shortcut settings.
On reboot, the system stuck on mouse pointer before the splashscreen appear.

Now, I’m writing from a live usb.
What is the file configuration to resetting the keyboard?
Can I do it from live? I can see my root partition.

inxi -Fza                                                           
System:
Host: manjaro-lxqt Kernel: 5.6.6-1-MANJARO x86_64 bits: 64 
parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=it_IT keytable=us tz=UTC 
driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
misobasedir=manjaro misolabel=MANJARO_LXQTM_200 quiet 
systemd.show_status=1 
Desktop: LXQt 0.14.1 Distro: Manjaro Linux 
Machine:
Type: Laptop System: LENOVO product: 80TL v: Lenovo V110-15ISK 
serial: <filter> 
Mobo: LENOVO model: Lenovo V110-15ISK v: SDK0J40697 WIN serial: <filter> 
UEFI: LENOVO v: 1KCN28WW date: 11/15/2016 
Battery:
ID-1: BAT0 charge: 28.1 Wh condition: 28.1/31.7 Wh (89%) 
CPU:
Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
family: 6 model-id: 4E (78) stepping: 3 microcode: D6 L2 cache: 3072 KiB 
Speed: 500 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 500 2: 500 
3: 500 4: 500 
Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
Type: l1tf mitigation: PTE Inversion 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass 
mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 
mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
IBRS_FW, STIBP: conditional, RSB filling 
Type: tsx_async_abort status: Not affected 
Graphics:
Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel 
Display: x11 server: X.org 1.20.8 driver: intel unloaded: modesetting 
resolution: <xdpyinfo missing> 
Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel 
Sound Server: ALSA v: k5.6.6-1-MANJARO 
Network:
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
driver: ath10k_pci 
IF: wlp2s0 state: down mac: <filter> 
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
driver: r8169 
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Device-3: Qualcomm Atheros type: USB driver: btusb 
Drives:
 Local Storage: total: 480.21 GiB used: 126.68 GiB (26.4%) 
ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-24VHAT0 
size: 465.76 GiB block size: physical: 4096 B logical: 512 B 
ID-2: /dev/sdb type: USB vendor: Toshiba model: TransMemory 
size: 14.45 GiB block size: physical: 512 B logical: 512 B 
Partition:
ID-1: / raw size: N/A size: 2.74 GiB used: 287.6 MiB (10.3%) fs: overlay 
source: ERR-102 
Sensors:
System Temperatures: cpu: 37.0 C mobo: 33.0 C 
 Fan Speeds (RPM): N/A 
Info:
Processes: 163 Uptime: 1h 37m Memory: 3.65 GiB used: 1.60 GiB (43.8%) 
Shell: zsh inxi: 3.0.37

I would be more precise:
I wanted to activate the META key for my laptop.

At first, in System > Input devices I click on ‘Advanced’ and 'Configure keyboard options" and I set the META key to left META (sorry, I don’t remember what is the exact option).
But it didn’t work. So, in Keyboard settings, I changed the “Generic 86 keys” to “Generic 105-key PC”
I reboot and I got the problem.
I think it is the first editing that hangs the boot (the META key did never work).

Maybe I could reset to default, if I knew where is the config file.
Any idea?

You are looking for /etc/X11/xorg.conf.d/00-keyboard.conf
Something of this sort:

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"
EndSection

Hi,
unfortunately, mine is the same to yours. Maybe the changes are not here…
How can I reset to default?

KDE Plasma stores that information in ~/.config/kxkbrc
Seems like i also have now Model=pc86
KDE Plasma defaulted all Generic to the Generic 86-key PC? Let me take a look at other installs i have and i’m sure i used to have the pc105.

What branch you are on?

Ok, thanks.
Stable branch.

Here my kxkbrc:

[Layout]
DisplayNames=
LayoutList=it
LayoutLoopCount=-1
Model=pc105
Options=compose:lwin,altwin:meta_win
ResetOldOptions=true
ShowFlag=false
ShowLabel=true
ShowLayoutIndicator=true
ShowSingle=false
SwitchMode=Global
Use=true

The modified date is compatible with the hour that I do the edit.

Maybe the two rows:

Model=pc105
Options=compose:lwin,altwin:meta_win

should be related to my changes.

There seems to be an inconsistency

image

On another install that Model entry is empty on my end, yet the settings display correct if i access the Keyboard Settings
Once on this install i removed the Model, as i have on the other install, and open both settings (the Keyboard is now integrated in the Plasma Settings under Input Devices) and Keyboard Settings = i get two different things between the two:

If you used the Keyboard from Input Devices then it might have a regression/bug, reason why it defaults and always displays the pc86, hence the Advanced Options get funky. Will have to investigate more about this.

yes I used the Input Devices.
Now, what can I do, please?
Delete the kxkbrc file? Is it safe?

No, deleting it might trigger the Input Device settings to take priority hence again making it as Model=pc86 instead Model=pc105 in a new file.
Just make that entry as Model= then reboot and hopefully the options you set will work, yet the system will take the correct pc105 from xorg config.

Ok, thanks for your help.

Can I edit the file from the live iso?

And should I delete the
Options=compose:lwin,altwin:meta_win
row too?

You can edit it from your session, even from TTY with nano
from this:

Model=pc105
Options=compose:lwin,altwin:meta_win

to this

Model=
Options=compose:lwin,altwin:meta_win

Not sure what this option does tho

and on my end is set to false

Make a test with your option and if doesn’t work then remove that line.

Thanks, I will try and report the result. :slightly_smiling_face:

@bogdancovaciu, I did the changes (I insert pc=86 too), but unfortunately, the boot didn’t arrive to desktop.
The system hangs on:
/dev/sda2: clean, 374339… etc
after the mouse pointer appears.

After I waited two minutes I tried to access to TTY, login and did the command startx, but I got the error:

xauth: timeout in locking authority file /home/user...... etc. and then the screen was black.

So, what can do now?
Maybe can I create a new user? Reinstall only KDE?
Please consider me almost a newbie.

That is unrelated to the keyboard issue, and means you have wrong permissions and ownership on your home user files and folders. Run this command to fix it:
sudo chown $USER:$USER $HOME
Reboot your system just in case after that.

No success! :sob:
Could do something from TTY, or I have to reinstall manjaro?
Any ideas?

Do this from TTY as your user:

mv .Xauthority .Xauthority_backup 

And then

xauth generate :0 .trusted

To be sure then run

systemctl reboot

After the second command and about 30 secs, I’ve got the same error:
xauth: timeout in looking authority file /home/user/.Xauthority

At reboot, same things.

:sob:

I prepared to reinstall the S.O.
Whit a Live ISO, I did a total and long backup.
While I was at it, I resize the /home partition to create a new DATA partition and then proceeded to copy my personal file.
I predicted that this procedure would take many hours, so I shutdown my laptop.

The follow day, I wanted resume the job, but I forgot to insert the usb live iso.
I let the boot go on, ready to REISUB but, to my great surprise, my desktop appared again!!! :money_mouth_face:
Now, my system works like a charm. :relieved:

I should point out that the only thing I did was to resize the home partition.
Supposedly, the keyboard thing was not the culprit.

It would be very interesting to know what might have happened to learn more about the “Linux Universe”, fascinating but sometimes puzzling for me. :heart_eyes:

If any experienced user could try to explain what happened, I would appreciate it.