After hardwareupgrade only black terminal screen with mouse cursor

I recently upgraded my storage/media rig from an AMD A10-7850K on an A88X FM2+ board to a Ryzen 5 5600G on a B550 AM4 board.

After the switch, It does not properly boot into KDE with only the cursor appearing and nothing else (aside from the terminal that is left over from decrypting boot).

When I try running startx it in another TTY, I get the error “amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-13)”

I tried both 5.15 and 5.16 kernels and neither worked…

EDIT: Works now after i uninstalled nomachine (AUR)

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  1. You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.