After computer crashed and restarted on an update, I can't log in to tty1

Hello friends, in an attempt to update the system recently my computer crashed and I had to restart the system, after that, I cannot log in to tty1, there are no graphics, but I can log in to other TTY’s normally.

Re-run update.

1 Like

Well, that’s another fine mess you’ve gotten yourself into, Stanley…
– Laurel and Hardy

As zbe suggests, run update again from whichever TTY works. Let me take a wild guess that you use Pamac-Manager GUI usually to update. This time, try the following Pacman command:

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu

This checks for the fastest mirrors available and then performs the update. It may take a minute to get started, but it should allow a smoother update overall.

I hope this helps. Cheers.

1 Like


Thanks for the answers, but I had already performed a system update on another tty. However, I still have the same error, I will paste here the execution of some commands that may be useful.

mhwd -li

                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

No installed USB configs!

Video-vesa and video-modesetting were installed later in an attempt to find a resolution, but it didn’t work either.

mhwd-kernel -li

Currently running:e[0m 6.6.8-2-MANJARO (linux66)
The following kernels are installed in your system:
   * linux510
   * linux54
   * linux61
   * linux66


[    12.019] (--) Log file renamed from "/var/log/" to "/var/log/Xorg.0.log"
[    12.019] 
X.Org X Server
X Protocol Version 11, Revision 0
[    12.019] Current Operating System: Linux kubr1ck 6.6.8-2-MANJARO #1 SMP PREEMPT_DYNAMIC Thu Dec 21 16:21:45 UTC 2023 x86_64
[    12.019] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64 root=UUID=cc93db5c-4c51-4ba7-8e8d-19d3eb513b20 rw quiet apparmor=1 security=apparmor udev.log_priority=3
[    12.019]  
[    12.019] Current version of pixman: 0.42.2
[    12.019] 	Before reporting problems, check
	to make sure that you have the latest version.
[    12.019] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    12.019] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec 31 16:14:58 2023
[    12.019] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    12.019] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    12.019] (==) No Layout section.  Using the first Screen section.
[    12.019] (==) No screen section available. Using defaults.
[    12.019] (**) |-->Screen "Default Screen Section" (0)
[    12.019] (**) |   |-->Monitor "<default monitor>"
[    12.020] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    12.020] (**) |   |-->Device "Device0"
[    12.020] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    12.020] (==) Automatically adding devices
[    12.020] (==) Automatically enabling devices
[    12.020] (==) Automatically adding GPU devices
[    12.020] (==) Automatically binding GPU devices
[    12.020] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    12.020] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    12.020] 	Entry deleted from font path.
[    12.020] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    12.020] 	Entry deleted from font path.
[    12.020] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    12.020] 	Entry deleted from font path.
[    12.020] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    12.020] 	Entry deleted from font path.
[    12.020] (==) FontPath set to:
[    12.020] (==) ModulePath set to "/usr/lib/xorg/modules"
[    12.020] (**) Extension "Composite" is enabled
[    12.020] (**) Extension "RENDER" is enabled
[    12.021] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    12.021] (II) Module ABI versions:
[    12.021] 	X.Org ANSI C Emulation: 0.4
[    12.021] 	X.Org Video Driver: 25.2
[    12.021] 	X.Org XInput driver : 24.4
[    12.021] 	X.Org Server Extension : 10.0
[    12.021] (++) using VT number 2

[    12.021] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    12.023] (II) xfree86: Adding drm device (/dev/dri/card0)
[    12.023] (II) Platform probe for /sys/devices/platform/simple-framebuffer.0/drm/card0
[    12.037] (--) PCI:*(7@0:0:0) 1002:15dd:1043:876b rev 198, Mem @ 0xe0000000/268435456, 0xf0000000/2097152, 0xfcb00000/524288, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    12.037] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    12.037] (II) LoadModule: "glx"
[    12.037] (II) Loading /usr/lib/xorg/modules/extensions/
[    12.040] (II) Module glx: vendor="X.Org Foundation"
[    12.040] 	compiled for, module version = 1.0.0
[    12.040] 	ABI class: X.Org Server Extension, version 10.0
[    12.040] (II) LoadModule: "vesa"
[    12.040] (II) Loading /usr/lib/xorg/modules/drivers/
[    12.040] (II) Module vesa: vendor="X.Org Foundation"
[    12.040] 	compiled for, module version = 2.6.0
[    12.040] 	Module class: X.Org Video Driver
[    12.040] 	ABI class: X.Org Video Driver, version 25.2
[    12.040] (II) VESA: driver for VESA chipsets: vesa
[    12.041] vesa: Refusing to run, Framebuffer or dri device present
[    12.041] vesa: Refusing to run, Framebuffer or dri device present
[    12.041] (EE) No devices detected.
[    12.041] (EE) 
Fatal server error:
[    12.041] (EE) no screens found(EE) 
[    12.041] (EE) 
Please consult the The X.Org Foundation support 
 for help. 
[    12.041] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    12.041] (EE) 
[    12.041] (EE) Server terminated with error (1). Closing log file.

re-run the update - and have it finish - on any one of the TTY’s you can log in

I already ran the update again, but the same error remained :confused:

inxi -Fazy
(or similar)
would be in order now, finally,
to let us see your hardware configuration

Your failure description is rather vague …

Sorry, I really forgot.

inxi -Fazy

  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=cc93db5c-4c51-4ba7-8e8d-19d3eb513b20 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Console: tty 2 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K/BR v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 5604
    date: 10/26/2020
  Info: model: AMD Ryzen 5 2400G with Radeon Vega Graphics bits: 64
    type: MT MCP arch: Zen level: v3 note: check built: 2017-19 process: GF 14nm
    family: 0x17 (23) model-id: 0x11 (17) stepping: 0 microcode: 0x8101016
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1827 high: 3600 min/max: 1600/3600 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3600 2: 1600
    3: 1554 4: 1600 5: 1600 6: 1600 7: 1600 8: 1468 bogomips: 57512
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: Safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    vendor: ASUSTeK PRIME driver: N/A alternate: amdgpu arch: GCN-5 code: Vega
    process: GF 14nm built: 2017-20 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.0 chip-ID: 1002:15dd class-ID: 0300
  Display: server: v: driver: X: loaded: vesa gpu: N/A
    tty: 240x67
  Monitor-1: Unknown-1 size-res: N/A in console modes: 1920x1080
  API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast inactive: wayland,x11
  API: OpenGL v: 4.5 vendor: mesa v: 23.1.9-manjaro1.1
    note: console (EGL sourced) renderer: llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio
    vendor: ASUSTeK PRIME B450M-A driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 07:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK PRIME B450M-A
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 07:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: N/A status: off with: pipewire-media-session
    status: off tools: pw-cli
  Server-3: PulseAudio v: N/A status: off with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: N/A modules: iwlwifi
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2725
    class-ID: 0280
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:3
    chip-ID: 0a12:0001 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 104
  Local Storage: total: 1.16 TiB used: 73.29 GiB (6.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: WDC WDS240G2G0A-00JH30
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0400 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-00WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: Ultra Fit
    size: 28.64 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1.00
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 83.07 GiB size: 81.21 GiB (97.76%) used: 73.27 GiB (90.2%)
    fs: ext4 dev: /dev/sda6 maj-min: 8:6
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.6 MiB (27.7%) fs: vfat dev: /dev/sda3 maj-min: 8:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 4 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 55.5 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 193 Uptime: 0m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 13.58 GiB used: 573.8 MiB (4.1%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1556 libs: 441 tools: pamac pm: flatpak pkgs: 0
  Shell: Bash (login) v: 5.2.21 running-in: tty 2 inxi: 3.3.31

Maybe it’s an old config acting out.
What do you have in /etc/X11?

ls -lA /etc/X11/*

There seem to be multiple issues; graphic drivers, X11 and fonts among them; broken or incomplete configurations. Allow me to be blunt; a full reinstall is the fastest way to have a working system once again.

If you already have your /home on a separate partition, that makes the process comparitively easy, and should allow keeping most of your previous customizations and settings.

If there is no separate /home partition, that makes it more difficult but not impossible, to do the same. However, I’d suggest the fastest then would be to selectively copy anything you want to keep, to another location, and perform a full reinstall.

Either way, if you reinstall, I suggest using the manual partitioning method, and create /home on its own partition.

That is all. Cheers.

why do you have installed all available drivers? dont do that!
remove these:

sudo mhwd -r pci video-modesetting
sudo mhwd -r pci video-vesa

there will probably be a vesa conf, so remove it too:

sudo rm /etc/X11/mhwd.d/vesa.conf


This was unexpected; even more unexpected, was that I missed it. As with most Linux packages, always uninstall one when trying another.

You know, Stanley, there’s a right and wrong way to do everything.
– Laurel and Hardy