After closing the lid, the WiFi turns off

Hello everyone!

I have an HP laptop running Manjaro XFCE, and my issue is that when I close the lid, it turns off the WiFi. How could I change this?

You possibly have your machine set to hibernate/sleep when the lid closes. If this is true, then it is expected that network devices will be deactivated also.

Change your power saving settings so that the computer locks the screen without hibernating. Don’t ask how to do that; I don’t use XFCE; and you’re expected to have some knowledge of your own computer. Good luck.

1 Like

Unfortunately, it’s already set up that way, and still, the WiFi turns off. I can’t seem to find any solution.

You can try editing (as root) : etc/systemd/logind.conf

uncomment the following and restart the computer:


Another possibilty is edit upower.conf in etc/UPower/UPower.conf


It still doesn’t work like this.

Is it possible to create a program that monitors the lid closure of a laptop and prevents it from turning off the wifi? Can you help me with this?

xfce4-power-manager inhibits logind handling suspend/hibernate and its keys to prevent conflicts

How can I make logind handle button events instead of xfce4-power-manager -

If you wish to have xfce4-power-manager not inhibit logind for a particular function, just set the value in xfconf’s Settings Editor or with xfconf-queries as shown below.

To have logind handle the lid open/close event:

xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -n -t bool -s true