After cloning clonezilla, disk B =1TB, affice the 500G of disk A

Hello :smile:
I used Clonezilla to clone my A drive: 500GB SSD, to a 1TB USB drive, in order to get extra space. The A drive has three partitions: one for manjaro, one for EFI, and one unassigned. Everything went well and I am booting without incident on the B drive, via USB.
The problem is that the partition manager shows me 931.51 GB for B, whereas when I add up the three partitions, I reach almost 500 GB only and not the 1 TB.

Could you please explain me how to successfully clone a 500 GB disk to a 1 TB disk, without it being restricted by half?

Translated with DeepL Translate: The world's most accurate translator (free version)

Can you post blkid and/or fdisk -l of the drives ?

clonezilla did what it had to do, it cloned a drive. in this case your drive B is a exact clone of your cloned drive a whith 500gb. in order to use your full drive b you have to extend the drive b via gparted !
don’t take it personal but your question shows up just a minimal knowledge and i recommend to do a deep research how to do this before you move to action.

a good tip:
download systemrescue or a similar tool. make a bootable stick with it, boot from this and alter the disk.

for more information i really recommend to search for “partitioning” in the internet and ask before acting. there is no dumb question but a lot of dumb actions.

Hi :grinning:,
Disque /dev/nvme0n1 : 476,94 GiB, 512110190592 octets, 1000215216 secteurs
Modèle de disque : KBG40ZNS512G NVMe KIOXIA 512GB
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d’E/S (minimale / optimale) : 512 octets / 512 octets
Type d’étiquette de disque : gpt
Identifiant de disque : 17877955-621E-6347-9C10-CCFC3C2BB976

Périphérique Début Fin Secteurs Taille Type
/dev/nvme0n1p1 2048 618495 616448 301M Système EFI
/dev/nvme0n1p2 421652480 1000214527 578562048 275,9G Système de fichiers Linux

Disque /dev/sda : 465,76 GiB, 500107862016 octets, 976773168 secteurs
Modèle de disque : WDC WD5000LPLX-0
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 4096 octets
taille d’E/S (minimale / optimale) : 4096 octets / 4096 octets
Type d’étiquette de disque : gpt
Identifiant de disque : 6DF3B447-33FD-424D-A626-6E5083CAEB6D

Périphérique Début Fin Secteurs Taille Type
/dev/sda1 2048 976766975 976764928 465,8G Système de fichiers Linux

Good evening,
Thank you for your feedback. Yes, I am a neophyte in this matter. :sweat_smile:
I thought of increasing the size of the cloning, but impossible since Clonezilla reduced my disk from 1Tb to 500Gb.
“there is no dumb question but a lot of dumb actions.” Totally agree. That’s why I put my problem on the site, having found no answer to my research. :wink:

Good evening to all,

I tested Timeshift using rsync: no incident during the procedure to an external disk. I can’t boot on the same capacity disk, on which I restore my backup. I don’t understand how this software works!

I created a new partition table on a 1TB disk, then the sizes of the partitions were identical. I then copied and pasted my original partions into those I had created. Of course, one after the other. But it was impossible to boot on the disk.

I then tried to repair the Grub via the super Grub2 image: still no boot possible. I tried via BootRepair64 (because I am in 64 bit), impossible to boot on the image.

I am washed out! Do you have any suggestion to make my HD bootable ?

that wasn’t the way it works. do you still have your 500gb as original. if so redo the cloning that you once did to the 1TB disk and make sure you can boot from the 1 TB disk. this disk will have 500 gb as the original. then you create a bootable stick with an operating system (i recommend systemrescue). you will boot from this stick and then you will start gparted and use the option to resize the disk.
make sure you are firm with gparted or partitionmanager. check youtube for the search item “gparted” and you’ll find a lot.

Thank you, I have already done so. Everything worked fine, except the size change which is impossible, as said in my previous message.

minute 4:25 and following

ok, merci. Je vais analyser les images, car je ne comprends pas bien l’anglais. :sweat_smile:

youtube hat auch französische beiträge :wink:

I’ve seen this type of video before that explains how Gparted works which is quite simple. Thanks to you. But as already explained: Gparted can’t expand partitions on disk which is displayed filled! Since CloneZilla clones the size of the 500GB disk to the 1TB one, reducing the latter to 500G. I have no possibility to stretch my 500G, there is no extra space displayed.

… different approach, but much easier in the end
no resizing necessary after the clone
(which, as you just now discover, is a real PITA - and takes a long time, too)

partition the new drive as you like/want it
create the filesystems in these partitions
set the proper attributes on the esp partition

then mount the partitions in the proper order to /mnt for example
or mount them one by one

… and just copy from old to new
(but not from the running system - use a live system
because of /dev and /sys and /proc for instance …)

The UUID’s of the partitions will be different
lsblk -f
will tell you these
adjust /etc/fstab and /etc/default/grub to reflect that

swap the disks
boot from USB
chroot into the new/copied system
and reinstall the boot loader
done

That is how I’d do it - how I have done it, and not just once.

1 Like

Hello everyone,

HELP ME PLEASE :disappointed_relieved:

Here are pictures of where I am, after transferring my data from 500 GB SSD to 1 T SSD. Neither Super Grub2, Gparted, not solved the problem.

If any of you would like to tell me the exact steps to solve this problem, I would love to hear from you. Thanks in advance.
[/url]https://i.postimg.cc/zDyWR0KG/20230108-091856.jpg

It seems you are trying to use instructions someone posted somewhere.
And you are (dare I say: mindlessly - meaning: not understanding what you do)
copy/pasting instructions that don’t make sense.

The chroot failed, this is what it looks like to me - that is the first thing.

When you use a Ubuntu/Debian based system like you do, getting into chroot is not as easy as typing: chroot …

And why would you try to remove these packages?

Lots of question marks and no answers - much more context is needed.

Hello,
The link posted is a return of one of many initiatives taken to try to use my lost system. Having been a long time ago on Ubuntu…
I would appreciate if you want help rather than judgments that do not build!
As for the context, it seems to me to be found in the title of my 1st post as well as in the following ones !

How to enter a chroot without the help of the
manjaro-chroot
or
arch-chroot
commands, which are only available to you when you use an Arch based system.

chroot - ArchWiki

Section 4.2 - the link goes directly to there

Perhaps that is more constructive and will get you somewhere.

I suggested another way apart from you trying to adapt your cloned system, but that would require you to start over.

Thank you for your feedback. I will read. :ok_hand:
And what do you think about the system mentioned above?

You mean your original starting point?
The 500GB disk cloned to a 1TB one?
… difficult, not worth investing in

No, I was thinking of this :wink:
La proposition de Olli > DistroWatch.com: SystemRescue