After booting with Live USB I only see black screen

It starts without any errors but then I just see a black screen.

No mouse.

1 Like

You could try Alt+Ctrl+F4 (or any F key except F2)

Does that get you to a terminal prompt? if so try going back to F2 (Alt+Ctrl+F2) does the desktop startup? this works on one of my Manjaro desktops and I haven’t got around to troubleshooting in more detail.

If not at least you’re now (hopefully) in a terminal so you can start to troubleshoot in more detail.

1 Like

I tried shortcuts it doesn’t work just black screen.

It was the same on EndeavourOS.

Are you using an NVidia GPU? You’ll likely get no display with most open source drivers if you are using an Ampere series GPU.

Try booting with the closed source/NVidia proprietary drivers.

1 Like


I’m using MSI RX 550 4GB.

I’ll try with onboard graphics now.

Did everything work with onboard graphics?

Might be worth hitting e at the Grub loader, to temporarily pass an argument upon OS load. Highlight the Manjaro entry, press the e key and add the following to the end of the linux entry:


See if it boots into the live environment then.

1 Like

I have tried with onboard but nothing is changed.

I will try what you said.


Try at the end of the line. The clue was in the error message, GRUB was looking to load a file called ‘nomodeset’ when it should have been trying to load the the files in /boot :wink:

1 Like

Now it’s stuck here.

I’m sorry, I can’t think of anything else it might be. I hope you find a solution!

1 Like