Adobe Flash not working in Brave or Firefox

Hi just want to report a issue that Flash and pepper flash on Firefox does not work but in Chrome and Chromium it does work.

I have flashplugin and pepper-flash installed

I can confirm this, but it’s not a Manjaro problem ─ or even a GNU/Linux problem ─ because the people I work with have reported the same thing in Apple macOS and Microsoft Windows.

Also, Chromium ─ which I myself am using ─ throws up a warning that Flash support will be discontinued on 31 December 2020. So I’m guessing it’s just the Flash plugin (and pepperflash) itself that is responsible for these oddities. :thinking:

Yeah I’m not saying it 's a Manjaro specific issue but on Windows I tested Firefox and it worked, I am not sure what the issue is but it says it’s installed and you can run it but it doesn’t actually run on my Manjaro but weirdly enough it does on Google Chrome and Chromium even tho Brave is based on it so something must be misconfigured for Brave and Firefox I assume. :slightly_smiling_face:

It doesn’t even run in Chromium here on my machine, even though it’s supposed to be active. :man_shrugging:

it must be a Firefox or Manjaro Problem. Flash in firefox the distri “siduction” working perfect

That’s wierd, for me flash works on both Chromium and Google Chrome but not Brave or Firefox anymore when tested

Now I have installed Vivaldi and it works

Hmm we need to figure out why some browsers work and some don’t and figure out what the issue is, Vivaldi is based on Chrome just like Brave but Brave doesn’t work and Firefox is having the same issue with it showing up installed but not working

Hi,
not sure it is not Manjaro issue because

  • presently Flash run under Windows Firefox
  • before last Manjaro release, Flash was well running with Manjaro Firefox

The last update included a new Flash player and a new pepperflash plugin, along with the warning ─ both in the package manager and in the browsers ─ that Flash becomes EOL in December 2020.

I guess Adobe broke it for their last effort. :man_shrugging:

It is a possible reason of missfonction . but in that case, why Flash still works under Windows ?
Adobe don’t like Linux ?

Actually, yes, they don’t like GNU/Linux. On several occasions over the past 20 years or so, they were offering updated plugins for Microsoft Windows but not for GNU/Linux, notwithstanding the loud complaints from the GNU/Linux community, and it was only when other alternatives became available in the market that they suddenly reprised their support for GNU/Linux.

Their software has always been problematic in GNU/Linux, even Acrobat Reader.

Any cases all should stop on the next 31st december…
So, sole solution is to wait for a new support
Thanks for your information. Bye

1 Like

RIght, it run on Chromium for me too.
Manjaro - KDE - basic stable and updated/ kernel 4.19/ HP Pavilion DV7
Both installed Flashpluging and Pepperflash.
Thanks to the Community.

Yeah but for some reason it won’t work on Firefox or Brave which is based on Chrome. It’s not for my case but for people who still use it and should at least work.

More …who is playing with the GNU softs or Freewares as VLC and Firefox for Linux ?
VLC and Firefox even Flashplayer all they run perfectly under Windows 10 ! and 7
What is happening ? Is there some worms inside the fruit ?

Found this, looks like it’ll be fixed once FF 81 is out on pamac. There is a dev version, but I haven’t tried it yet.

1 Like

Hi guys !
Flashpluging works with Firefox… from today newly updated …
i think Chromium will be preferred
I really don’t appreciate this delay !
The End.