ADF not working Brother LW2730

Hi, i dont have high hopes for an answer, but perhaps someone has a solution

i have the named printer (printing works) and try to get the ADF working. I have installed brscan5 and brscan-skey, the flatbed scanner works, just not the ADF. Not one scannerapp is recognizing the ADF.
The weird thing is, i had it working some weeks ago. Looks like an update killed the functionality.

Any idea what to do ?

Maybe this can help?

Thank you very much for answering, but thats not the solution.

  1. i dont have auto crop in the brother software
  2. ADF is and was working perfectly fine under windows.
  3. its not related to L2730DW

this are the details which prevent the year of the linux desktop.
Meanwhile I would take a prop. software for that daily stuff, really, can it plz just - work ? :wink:

If you know when it stopped working you can search for an updated package which could possibly be the culprit.

cat /var/log/pacman.log | grep <date>

Then search for previous versions in pacman’s cache.

ls -la /var/cache/pacman/pkg | grep <package-name>

Then try to install a previous version.

sudo pacman -U <path>

Don’t forget to reload and restart needed services.

Completely agree. Sometimes it sucks, but most of the time it’s well worth it.

i dont know when, so thats no solution

Just installed the brother driver packages on my wifes Kubuntu, scanner ADF works oob. :frowning: Only difference i saw, was that the package was installing brsaneconfig4 instead of 5.
So i switched to that on manjaro but no luck.

So, how do i install a rpm/deb package ?

You can see the version of cups and driver, for example, then see which versions you have in your package cache.

That’s not the right conclusion. You can still look for older versions in your cache and try them. Don’t forget to reload and restart services, or reboot, after installing a new package (especially cups).

ok, thx, i try that when my system is booting again. After the last updates 2 days ago i have only a black screen with cursor and tty login says wrong password. I hope one of the posted solutions works

Updates don’t change passwords.

Take a look here:


looks like i got it solved (without deb package), not very clean but the ADF is recognized by skanlite

Had to add the scanner with brsaneconfig5 -a FRIENDLYNAME,NAME, IP etc

No i have a third scanner device with ADF

device v4l:/dev/video2' is a Noname UVC Camera (046d:0825) virtual device device escl : http: //’ is a ESCL Brother MFC-L2730DW series flatbed scanner
device `brother5:net1;dev0’ is a Brother

where is that name (brother5) coming from ? This is all so weird :wink:

I’d guess the IP changes and every time this happens you add a new device, which is actually the same one with a different name and IP.

If this is the case, give a static IP to the device and update the IP in properties instead of adding a new one.

Or I could be wrong. It’s just what seems more plausible.

the IP is static. Forget it, i figure it out, ADF is working, so problem is solved more or less

Can you please share the solution?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.