Adding Linux Mint boot option to Manjaro system

I want to install an alternative Linux XFCE disto alongside my Manjaro installation. The reason is I’m trying to get to the bottom of why my computer has started malfunctioning. It’s less than a year old and I doubt it’s a hardware issue.

I have a separate physical drive mounted as /home so that all my work is relatively safe and would like to mount that as /home on both Manjaro and Mint. I created a bootable Mint installation USB, and I read that Manjaro grub can boot Mint but not the other way round. I’m not sure at what point I will get to make critical decisions so I’m just asking before I mess it all up (as usual) if anyone has any recommendations what to avoid and what the best way to go about it please?

Note: My main reason is that Shotcut (video editor) has become completely unpredictable: Sometimes it freezes and other times exits with segmentation fault. Lately it’s GUI interface is incomplete (e.g. no time line). I tried uninstalling and installing again, but that doesn’t actually change anything. I did install it on a Windows laptop only to see that it works fine there albeit a bit limited by the small single screen and naff mouse pad… not to mention the ghastly Windows operating system that I definitely don’t want on my desktop machine.

Thanks in advance for any input. Meanwhile I shall make sure I have my backups fully up to date this time.

and would like to mount that as /home on both Manjaro and Mint.

This is not a good Idea.
The reason is:
in that /home folder is not only all your stuff
but also there are all the hidden files which control all your settings for the particular Desktop Environment you choose to use.
These will almost certainly be at least slightly different and will cause problems in the new installation as well as in the existing one.
The ./.mozilla (if you use Firefox) and the ./.thunderbird (if you use Thunderbird for mail) are probably ok to share between systems
But not all the rest of the hidden files.
They will interfere.

People have done this or at least wanted to - and there are topics here which discussed that and advice on how to best do that.
Try reading and looking around a bit to find those? :wink:

1 Like

I had a Win10 PC, Windows installed on my SSD
Then I installed Manjaro on my HDD, same PC, root Partition, /home and swap space on the HDD, /boot/efi on SSD where Win10 is installed.
Now installing Mint (Mate I believe), root, /home and another swap partition on the HDD, but I don’t know where to put the /boot partition. Also I don’t know if I should mount it as /boot or /boot/efi
When I turn on the PC a Manjaro Boot Menu shows up where I can decide to boot Manjaro or Win10, I would like that the option to boot into Mint would also appear in the same menu.

Note: My main reason is that Shotcut (video editor) has become completely unpredictable …

One reason for the freezing that you experience could be that you run low on memory - check whether you have swap and that it is “mounted”.
swapon -s
free -h
as well as
are ways to see that.

Another reason, for the incomplete GUI and such, could be the theme that you use. Try changing that.

Next I’d copy to a backup folder all the configuration files,
and then delete them, but only after you made a copy!
either for shotcut alone
or just everything.
These are the hidden files in your /home/$user in directories like ~./.config and ~./.cache
deleting ~./.cache isn’t critical, but
… if you remove ~./.config your custom look and all the settings will be gone - but you can restore from the backup copy

That’s probably easier than to install an entire system alongside - as I said: sharing /home between them is not a good idea.

1 Like


Have you tried here and on to ask for support for the crashing/freezing problem problem? It might just come back in a new install. If you are happy with what you have now it pay’s off to get if fixed.

1 Like

if you look at the contents of /etc/skel
it’s all hidden files and directories - all starting with a . (dot)
you’ll find that it contains the current default settings - which will, when copied to your /home/$user
provide you with the default look and settings like they are in a fresh installation

Do a full backup of your /home/$user - including all the hidden files,
and then delete them,
prior to installation of a fresh system

restore what you need after installation from the backup

What makes things easier (IMO) is when you can look at what you are working on one side, while, at the same time, seeing what is on the other side

I use “mc” all the time

  • it’s a terminal program looking like it is from the olden days
    It displays the hidden files and directories by default

I find it much better than any console or even graphical file manager
… to you, mentally keeping track of what is going on … what is going where …

… things where done like this in the '90s’ :wink:

1 Like

That’s really useful info.

What I had already done, rather than delete my own hidden files is to create a brand new user (by a different name) but she also had exactly the same problems with shotcut, right from the start.

It does however appear to ONLY be related to shotcut. I have not seen the problem with any other app (yet). The issues started around about the time I updated my Nvidia drivers not long ago, but then with their removal in a recent update. I had a total system lockup with no choice but to reinstall everything from scratch.

The memory issue I checked.

It says I have 60Gi free &940Mi in use.
The swap area is probably irrelevant as I had let it configure the default … which appears to be 8.8Gi and none of that is in use.

I did a full update again but immediately on running shotcut (in debug mode) I get this:

[Debug ] Player::setIn in -1 out -1
[Debug ] Player::setOut in -1 out -1
[h264 @ 0x55f0d4e4a8c0] Reinit context to 1920x1088, pix_fmt: yuv420p
[h264 @ 0x55f0d4e9edc0] Reinit context to 1920x1088, pix_fmt: yuv420p
[h264 @ 0x55f0d4fda540] Reinit context to 1920x1088, pix_fmt: yuv420p
[Debug ] [producer avformat] audio: total_streams 1 max_stream 1 total_channels 2 max_channels 2
[AVIOContext @ 0x55f0d4e519c0] Statistics: 7256993 bytes read, 2 seeks
[Debug ] [mlt_producer avformat-novalidate] “/home/angelica/Videos/lauren/Crossfire-495518160.mp4” checking VFR: pkt.duration 3753
[h264 @ 0x55f0d5514480] Reinit context to 1920x1088, pix_fmt: yuv420p
[Debug ] TimelineDock::setSelection Changing selection to () trackIndex -1 isMultitrack true
[Debug ] VideoVectorScopeWidget::profileChanged 709
[Info ] MainWindow::open “/home/angelica/Videos/lauren/lauren.mlt”
[Debug ] TimelineDock::setSelection Changing selection to () trackIndex -1 isMultitrack false
[Debug ] AudioLoudnessScopeWidget::resetQview begin
Segmentation fault (core dumped)

So I think I need to talk to Shotcut. It’s unlikely a Manjaro issue although could be the audio driver.
I was hoping to confirm that on another Linux disto, but alas it’s not an easy test to do. So I’m gunna do nothing for now.

Thanks for that link. I will do that and have just joined their forum but am still in restricted mode as newbie.

I did find thread about tripple boot here: Triple Boot windows/ Manjaro Linux/ Linux Mint
Alas it didn’t really help me as I don’t really know why I should need UEFI … or where to select that yet.

hmm - then @Hanzel 's suggestion would indeed be more … promising

1 Like

Right… well I worked my way thru the @discobot tutorial and then searched the FAQ. Finally decided to download their latest zip file before saying anything… and well it works fine… so it looks like the pamac version is the problem?!
For me it’s working. I can get back to my work and I could just walk away, but realistically I would like to help sort it out for others too if I can help.
Any suggestions of what I should to be of any use on this?